Bug 73024 - missing dependency on libelf?
missing dependency on libelf?
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 20:32 EDT by Alexandre Oliva
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 20:32:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-08-29 20:32:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
After upgrading up2date to 2.9.55-2 and rpm to 4.1-1.0, up2date will no longer
run.  I had to update libelf to 0.8.2-2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install null
2.Update up2date and rpm from the RHN null channel
3.Try to run up2date again


Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpmdb-4.1.so: undefined symbol: gelf_getehdr


Expected Results:  rpm should have refused to upgrade itself to rpm 4.1 because
of the missing dependency on (the newer version of) libelf.

Additional info:
Comment 1 Jeff Johnson 2002-08-30 09:25:06 EDT
Fixed in rpm-4.1-1.03

Note You need to log in before you can comment on or make changes to this bug.