Bug 730240 - Version bump for parcellite 1.0.2rc5
Summary: Version bump for parcellite 1.0.2rc5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: parcellite
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 09:26 UTC by Lukas Zapletal
Modified: 2012-03-09 04:53 UTC (History)
4 users (show)

Fixed In Version: parcellite-1.0.2-0.1.rc5.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-03 16:07:06 UTC


Attachments (Terms of Use)
git format-patch against master (2.91 KB, patch)
2011-08-12 09:27 UTC, Lukas Zapletal
no flags Details | Diff

Description Lukas Zapletal 2011-08-12 09:26:18 UTC
Hello,

I made a patch against current master/rawhide to bump the version to 1.0.2rc3.

Parcellite has new upstream author, different versioning scheme (long release candidates).

It has new nice features.

I had to modify the DSO patch because there are new dependencies introduced.

Attaching...

Comment 1 Lukas Zapletal 2011-08-12 09:27:35 UTC
Created attachment 518005 [details]
git format-patch against master

Comment 2 Lukas Zapletal 2011-08-12 09:34:04 UTC
Fedora rawhide scratchbuild: http://koji.fedoraproject.org/koji/taskinfo?taskID=3267872

Comment 3 Michael Cronenworth 2011-11-08 18:28:28 UTC
1.0.2rc5 is now the current version. Could we see it in rawhide? Thanks.

Comment 4 Ankur Sinha (FranciscoD) 2011-12-07 15:19:55 UTC
Hello Cristoph,

Could we see this in F16 too? It fixes some bugs apparently. (One of them is a nagging one where after a ctrl C, it replaces my current clipboard with whatever text I highlight!) If you need help maintaining this package, I could co-maintain it and assist you.


Thanks
Ankur

Comment 5 Fedora Update System 2012-03-03 15:57:41 UTC
parcellite-1.0.2-0.1.rc5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/parcellite-1.0.2-0.1.rc5.fc17

Comment 6 Christoph Wickert 2012-03-03 16:07:06 UTC
(In reply to comment #4)
> Could we see this in F16 too? 

No, the behavior has changed and the new version is not compatible with our update policy. See https://fedoraproject.org/wiki/Updates_Policy
I will only push it to Fedora >= 17

> It fixes some bugs apparently. (One of them is a
> nagging one where after a ctrl C, it replaces my current clipboard with
> whatever text I highlight!)

This is not a bug but a feature. Linux has 2 clipboards:
1. The classical X clipboard ("primary selection"). Copy by simply selecting some text, paste with middle mouse button.
2. Most desktops also have a new windows-like keyboard with Ctrl+C/X/P

If you enable the 'sync' option in parcellite, the contents of one clipboard is immediately pasted to the other. Quote from the home page:

"NOTE (this should go in the man page…eventually):
Primary means mouse copy/paste, and this is the X ‘primary’ clipboard
Ctrl-C is the keyboard copy/past, and this is the X ‘clipboard’ clipboard
Syncronize means if you copy with either, it pastes immediately to the other one.
If not syncroized, if you use Ctrl-C, then try to paste with middle mouse, you will get whatever was in the primary keyboard (the last thing you copied with the mouse)."

Turn or syncing and everything should be fine.

Any other bugs that you think are fixed?

Comment 7 Fedora Update System 2012-03-09 04:53:54 UTC
parcellite-1.0.2-0.1.rc5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.