Bug 730244 - libvirt error message should show the uri content but not (null)
Summary: libvirt error message should show the uri content but not (null)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 09:40 UTC by weizhang
Modified: 2011-12-06 11:26 UTC (History)
6 users (show)

Fixed In Version: libvirt-0.9.4-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: Invalid variable was used to construct the error message. Consequence: If a migration command has failed, the error message reported the remote URI to be '(null)' instead of the requested migration URI. This could hide the reason why the command failed. Fix: Error message is constructed using the correct variable containing the migration URI. Result: Correct migration URI is reported on error.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:26:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description weizhang 2011-08-12 09:40:00 UTC
Description of problem:
When do p2p migration to an unknown host, libvirt will report error like
error: operation failed: Failed to connect to remote libvirt URI (null)
here the "(null)" should be the uri content.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start a guest
2. do migration with command
# virsh migrate --p2p guest qemu+ssh://1.1.1.1/system
  
Actual results:
error: operation failed: Failed to connect to remote libvirt URI (null)

Expected results:
error: operation failed: Failed to connect to remote libvirt URI qemu+ssh://1.1.1.1/system

Additional info:

Comment 4 weizhang 2011-08-23 06:02:18 UTC
Verify pass on
libvirt-0.9.4-5.el6.x86_64

# virsh migrate --p2p guest qemu+ssh://1.1.1.1/system
error: operation failed: Failed to connect to remote libvirt URI qemu+ssh://1.1.1.1/system

Comment 5 Peter Krempa 2011-11-11 10:02:50 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
Invalid variable was used to construct the error message.

Consequence:
If a migration command has failed, the error message reported the remote URI to be '(null)' instead of the requested migration URI. This could hide the reason why the command failed.

Fix:
Error message is constructed using the correct variable containing the migration URI.

Result:
Correct migration URI is reported on error.

Comment 6 errata-xmlrpc 2011-12-06 11:26:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.