Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 73027 - incorrect dependency on libgd breaks apache
incorrect dependency on libgd breaks apache
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: 78696 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-08-29 20:45 EDT by Ganesh Sittampalam
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-05 08:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ganesh Sittampalam 2002-08-29 20:45:17 EDT
Description of Problem:
There should be a dependency on libgd.so.1.8.4 (or the gd-1.8.4 
package) - with gd-1.8.3 /usr/lib/apache/libphp4.so has an unresolved symbol (I ran into this 
trying to upgrade slowly and carefully from RH7.1 to RH7.3)

Version-Release number of 
selected component (if applicable):
php-4.1.2-7.3.4 and gd-1.8.3-7

Install these packages

Steps to Reproduce:
Start Apache

Apache fails to load libphp4.so, complaining about unresolved symbol 

Expected Results:
Apache should have loaded

I don't know if the procedure of upgrading Redhat versions bit by bit is 
officially "supported", but it is absolutely essential for upgrading a server while trying to 
keep services running as much as possible,
Comment 1 Phil Copeland 2002-08-29 21:44:29 EDT
gdStringFT ? never heard of it. Doesn't even exist in the gd libs

[root@dhcp59-221 root]# nm  /usr/lib/libgd.* | grep -ic gdStringFT

[root@alpha php-4.1.2]# grep -irc gdStringFT *

Not directly referanced by anything in the php codebase either.
google has never heard of it either...

Sorry, I can find no referance to this gdStringFT in the codebase.

Oh wait, you did a jump from 7.1 to 7.3? how as an upgrade install? As a rpm
-Fvh against an RPMS directory?

Comment 2 Ganesh Sittampalam 2002-08-29 21:50:00 EDT
Sorry, my mistake, that should be gdImageStringFT. It's in the 7.3 version of gd but not the 7.1 

I upgraded by manually upgrading small dependency groups of RPMs at a time 
(actually using apt-rpm, but that just calls rpm -U to do its work).
Comment 3 Phil Copeland 2002-08-29 22:59:26 EDT
Ok so it's a BuildRequires: gd >= 1.8
it's added for errata but for now as you've already seen, just update gd

Comment 4 Ganesh Sittampalam 2002-08-29 23:05:38 EDT
surely it's "Requires: gd >= 1.8.4"? I wasn't trying to build it and the difference between 1.8.3 
and 1.8.4 is significant, since it's in 1.8.4 that the symbol appears.
Comment 5 Phil Copeland 2002-08-30 00:47:57 EDT
yes, sorry, not getting enuf sleep here...
Comment 6 Joe Orton 2002-09-26 04:51:26 EDT
Leaving this open whilst an errata is still pending.
Comment 7 Joe Orton 2002-11-29 12:25:25 EST
*** Bug 78696 has been marked as a duplicate of this bug. ***
Comment 8 Joe Orton 2002-11-29 14:29:53 EST
*** Bug 78696 has been marked as a duplicate of this bug. ***
Comment 9 Joe Orton 2004-04-05 08:39:34 EDT
Thanks for the reports.  This is fixed in all current releases.

Note You need to log in before you can comment on or make changes to this bug.