Bug 730303 - Need to increase VG_N_SEGNAMES
Summary: Need to increase VG_N_SEGNAMES
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: valgrind
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Mark Wielaard
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 12:18 UTC by Jon Masters
Modified: 2016-01-11 13:15 UTC (History)
7 users (show)

Fixed In Version: valgrind-3.8.1-3.1.el6
Doc Type: Bug Fix
Doc Text:
Previous versions of valgrind might report "Valgrind: FATAL: VG_N_SEGNAMES is too low." when running larger (C++) programs under valgrind. This version has increased the compile time constants VG_N_SEGMENTS to 50000 and VG_N_SEGNAMES to 25000 to prevent this error. Upstream description here: https://bugs.kde.org/show_bug.cgi?id=164485
Clone Of:
Environment:
Last Closed: 2013-02-21 08:50:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0347 normal SHIPPED_LIVE valgrind bug fix and enhancement update 2013-02-20 20:53:42 UTC
KDE Software Compilation 164485 None None None Never

Description Jon Masters 2011-08-12 12:18:16 UTC
I'm unable to use valgrind to debug an application due to the 1000 limit, and others have experienced this, too. Can we please bump to 4000, or similar? At the moment, I'm using a custom built valgrind on RHEL6 to avoid it just aborting.

Comment 2 Miroslav Franc 2012-03-06 10:52:34 UTC
This is already tracked by upstream bugzilla.

Comment 4 RHEL Product and Program Management 2012-07-10 08:35:38 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Product and Program Management 2012-07-11 01:54:14 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 6 Mark Wielaard 2012-10-14 19:51:17 UTC
Another instance/reproducer:

$ valgrind -q stap -v -l 'module("*").function("*_exit")' 
Pass 1: parsed user script and 99 library script(s) using 525708virt/314040res/4068shr/338080data kb, in 8820usr/180sys/9060real ms.
--12587:0:aspacem  Valgrind: FATAL: VG_N_SEGNAMES is too low.
--12587:0:aspacem    Increase it and rebuild.  Exiting now.

The upstream setting of VG_N_SEGMENTS and VG_N_SEGNAMES have been kept low to support devices with just 512MB of memory that run large C++ applications under valgrind anyway. With the current upstream setting of 5000 for VG_N_SEGMENTS and 1000 for VG_N_SEGNAMES the static segnames[] and nsegments[] take up ~1.2MB. For server and workstation machines it should be fine to increase these (suggested values VG_N_SEGMENTS 50000 and VG_N_SEGNAMES 25000) to make these use up to ~26MB.

Note: above reproducer will take a couple of minutes to complete under valgrind (with a patch to increase VG_N_SEGMENTS and VG_N_SEGNAMES).

Comment 7 Frank Ch. Eigler 2012-10-15 15:22:23 UTC
scratch build available

Comment 11 errata-xmlrpc 2013-02-21 08:50:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0347.html


Note You need to log in before you can comment on or make changes to this bug.