Bug 730389 - rc.sysinit needs to run multipath and kpartx with the -u option.
Summary: rc.sysinit needs to run multipath and kpartx with the -u option.
Keywords:
Status: CLOSED DUPLICATE of bug 729680
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 631009 1257704
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 18:30 UTC by Ben Marzinski
Modified: 2015-08-27 17:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-15 17:10:12 UTC


Attachments (Terms of Use)
patch to add -u to multipath and kpartx calls. (692 bytes, patch)
2011-08-12 18:30 UTC, Ben Marzinski
no flags Details | Diff

Description Ben Marzinski 2011-08-12 18:30:26 UTC
Created attachment 518086 [details]
patch to add -u to multipath and kpartx calls.

udev was unecessarily calling blkid whenever multipath and kpartx devices got reloaded, including when they got reloaded with no working paths.  This caused the device to get stuck open. To fix this multipath and kpartx pass a flag to skip this step whenever the device already exists.  However these rules must be run by rc.sysninit during bootup, in case the devices were created in the initramfs.  To do that multipath an kpartx need to be called with the -u option in rc.sysinit.

Comment 1 Ben Marzinski 2011-08-15 17:10:12 UTC

*** This bug has been marked as a duplicate of bug 729680 ***


Note You need to log in before you can comment on or make changes to this bug.