Bug 730409 - Can't search systems on Environments sub-subtab
Summary: Can't search systems on Environments sub-subtab
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 742017 katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-12 20:02 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:52:17 UTC


Attachments (Terms of Use)
Before entering the search text (52.84 KB, image/png)
2012-01-02 10:35 UTC, Sachin Ghai
no flags Details
The filtered system name, after entering the sys text in search box.. (47.50 KB, image/png)
2012-01-02 10:37 UTC, Sachin Ghai
no flags Details

Description Jeff Weiss 2011-08-12 20:02:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.61-1.git.30.a7174a6.fc14.noarch

How reproducible:
always

Steps to Reproduce:
1. Create an environment, register a system to that environment.
2. Navigate to the Systems/Environments page
3. In the environment select widget, select your environment.
4. In the search bar, type part of the name of your system.
5. Hit enter
  
Actual results:
The page reloads and the environment in the select widget reverts to
Locker.  No results are shown.

Expected results:
Your system is displayed in the left pane, your environment remains
selected in the widget.

Additional info:

Comment 1 Brad Buckingham 2011-12-12 22:22:38 UTC
Looks like this may have been resolved as part of search refactorings in recent sprints.  Moving to ON_QA to have QA take a look.

Comment 2 Sachin Ghai 2012-01-02 10:33:17 UTC
verified with following katello build:

[root@dhcp201-197 ~]# rpm -qa | grep katello-0
katello-0.1.155-1.el6.noarch
[root@dhcp201-197 ~]# 

I can search systems on Environement sub-subtabs.

Please see the attachment in next comment

Comment 3 Sachin Ghai 2012-01-02 10:35:25 UTC
Created attachment 550232 [details]
Before entering the search text

Comment 4 Sachin Ghai 2012-01-02 10:37:11 UTC
Created attachment 550233 [details]
The filtered system name, after entering the sys text in search box..

Comment 7 Mike McCune 2013-08-16 18:21:35 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.