Bug 730415 - kickstart with user --name=blah results in traceback
kickstart with user --name=blah results in traceback
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2011-08-12 16:27 EDT by Brian Lane
Modified: 2011-09-22 21:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-16.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 21:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2011-08-12 16:27:50 EDT
users.createUser() has an argument named 'name', the kwargs passed cannot contain name without raising a TypeError.
Comment 1 Tim Flink 2011-08-12 16:50:34 EDT
Can you elaborate on the impact of this bug a little more? I don't understand what the user would hit for this.
Comment 2 Brian Lane 2011-08-12 17:13:30 EDT
Anyone doing a kickstart install which sets up users will hit this.
Comment 3 Tim Flink 2011-08-12 17:27:00 EDT
Is there an estimated timeline for when a fix might be ready and how invasive it would be?

This isn't covered explicitly by any of the alpha release criteria but that doesn't mean that it can't be an alpha blocker since the result is rather nasty.

[1] http://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 4 Adam Williamson 2011-08-15 13:08:05 EDT
Discussed at the weekly QA meeting of 2011-08-15 (with anaconda team and releng in attendance). Rejected as blocker and NTH: we felt this doesn't hit any Alpha criteria, and though it's a bad bug, it's too late to take as NTH for Alpha, we want minimal changes for RC4. Re-proposing as Beta blocker.
Comment 5 Tim Flink 2011-09-01 13:36:58 EDT
Discussed in the 2011-08-26 blocker review meeting. No decision was made regarding blocker status because details about the kickstart release criteria have not yet been finalized.

Accepted as NTH for Fedora 16 beta because this isn't an uncommon use case.
Comment 6 Adam Williamson 2011-09-02 13:22:32 EDT
bcl says the fix made 16.16, so we should now be able to re-test this.
Comment 7 Adam Williamson 2011-09-07 17:37:13 EDT
I think this probably depends on 734861.
Comment 8 Adam Williamson 2011-09-07 18:31:49 EDT
actually, since you can do a GUI kickstart install, it really doesn't...

so, I tested this, with this line in my .ks:

user --name=test --password=test --plaintext

the install was successful and the user 'test' shows up in /etc/passwd , but trying to login with username test, password test gives 'Login incorrect'. Did I do something wrong with the parameters, or is that another bug?

This bug does seem fixed, though.
Comment 9 Adam Williamson 2011-09-07 18:33:21 EDT
there's no /home/test either...
Comment 10 Adam Williamson 2011-09-09 13:22:22 EDT
this was discussed at the 2011-09-02 blocker meeting and agreed to be RejectedBlocker, but we didn't update the bug - doing so now.
Comment 11 Adam Williamson 2011-09-22 21:26:39 EDT
16.18 is in stable now. This bug is fixed, the symptoms I saw in comment #8 relate to another bug.

Note You need to log in before you can comment on or make changes to this bug.