Bug 730417 - remove '--with smp' kernel spec file option and replace with working '--with up'
Summary: remove '--with smp' kernel spec file option and replace with working '--with up'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 20:36 UTC by Matthew Whitehead
Modified: 2011-08-15 18:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-15 18:07:54 UTC


Attachments (Terms of Use)
Fix with_up to work (4.63 KB, patch)
2011-08-15 17:51 UTC, Josh Boyer
no flags Details | Diff

Description Matthew Whitehead 2011-08-12 20:36:52 UTC
Description of problem: Presently there is a "--with smp" kernel.spec option for use with rpmbuild. However, all current kernel config files except arm and powerpc32-generic enable the smp option. For most architectures you cannot opt-out of smp using "--with up".

Version-Release number of selected component (if applicable): RHEL > 4


How reproducible: 100%


Steps to Reproduce:
1. Build a kernel using rpmbuild and '--with up'. It will NOT build a uniprocessor kernel because the config files override it.
2.
3.
  
Actual results: SMP kernel.


Expected results: Uniprocessor kernel.


Additional info:

Comment 1 Josh Boyer 2011-08-15 12:04:34 UTC
An x86 SMP kernel will realize there is only one CPU and patch out various sections of SMP code to act as a UP kernel.  Why do we need to force a UP kernel?

Comment 2 Matthew Whitehead 2011-08-15 12:56:58 UTC
We need to force a UP kernel on systems that have > 1 core, but you want to test UP behavior. It's not the same as setting MAXCPUS=1.

Comment 3 Josh Boyer 2011-08-15 17:51:14 UTC
Created attachment 518300 [details]
Fix with_up to work

I'm not sure who "we" is in this context, but something like the attached patch would be needed.  I wouldn't expect Fedora to build this by default at all, but it would make the with_up setting a viable option for those wanting to do that kind of debugging with a local build.

Comment 4 Dave Jones 2011-08-15 18:07:54 UTC
I'm hesitant to further ugly up the spec & config set with something this niche.
We don't ship UP builds, so this is purely a minority development knob.

Rather than make the rats-nest of config generation even more complicated, I'm closing this WONTFIX.  If you want to do a build with config options we don't ship/support, either make those changes locally, or do a non-rpm based build.


Note You need to log in before you can comment on or make changes to this bug.