Bug 73043 - Non-DHCP configuration UI needs improvement
Non-DHCP configuration UI needs improvement
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 23:20 EDT by Ed Halley
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 22:48:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Halley 2002-08-29 23:20:49 EDT
Description of Problem:

  The user interface for DHCP/nonDHCP network configuration needs work.

  The setup screen for configuring the network defaults to DHCP setup.
  Below the fields for DHCP paramters, many disabled fields show the
  manual parameters such as gateway and nameserver addresses.

  To switch off DHCP, the user must currently click a button to show
  a popup dialog, then configure manual parameters, then RETURN to the
  main screen, and continue adding manual parameters.

  Instead, the interface should be simpler.  A suggested interface:

  +-- Network Configuration Type -------------+
  | (*) Automatic DHCP  ( ) Manual Fixed-IP   |
  +-------------------------------------------+
  +-- DHCP Parameters ------------------------+
  |                                           |

  If the DHCP option is chosen, then all DHCP fields should appear
  below these two choices.  If the Manual Fixed-IP choice is chosen,
  then the irrelevant DHCP fields should be hidden and replaced with
  the manual fields.  Flipping back and forth should remember and
  restore any values in the fields.

  +-- Network Configuration Type -------------+
  | ( ) Automatic DHCP  (*) Manual Fixed-IP   |
  +-------------------------------------------+
  +-- Fixed IP Parameters --------------------+
  |                                           |

  If an additional popup dialog is required, then it should fit ALL
  the relevant fields, not just a portion of them.  Don't offer a
  manual ternary (third) DNS host, since most people won't have
  three addresses from their ISP, or will know how to add one later.
Comment 1 jrjohns 2002-09-08 20:14:32 EDT
Hearye hearye, I agree.  This page is very confusing.  As currently implemented,
it isn't immediately apparent on the screen for network configuration that I
needed to click the 'Edit' button to define host information manually on a popup
dialog, then come /back/ to the net config page to add additional information
below for gateway and DNS.  The selection for DHCP versus manual hostname
detection in the middle of the page seems redundant after I had to 'Edit' the
information above to manually enter host information already (if I'm going to
manually set the IP address, why even ask me if I want to fetch the hostname by
DHCP?  Yes, it greys itself out automatically but before clicking 'Edit' I was
first attracted to the middle of the screen because 'manual vs DHCP' was the
first question on my mind to answer).  I can understand that this page is
designed to be really easy for most people who are just going to use DHCP, but
it is needlessly complex for anyone straying from that path.  I applaud the
attempt to improve things... you just need to try again. :)
Comment 2 Jeremy Katz 2003-10-15 18:37:06 EDT
Handling one interface is simple, because then everything applies equally well.
 When you have more than one interface and they're shared between being dhcp and
manual is when things get tricky.

I'm not against ideas (for FC2 at this point), but nothing better has come to my
mind yet.
Comment 3 Jeremy Katz 2004-10-04 22:48:56 EDT
I think that this is a little bit better now. 

Note You need to log in before you can comment on or make changes to this bug.