Bug 73047 - up2date does not close fds
Summary: up2date does not close fds
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: null
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-30 04:48 UTC by Scott Lamb
Modified: 2015-01-08 00:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-31 02:33:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date's 384 open fds (38.59 KB, text/plain)
2002-08-30 05:46 UTC, Scott Lamb
no flags Details

Description Scott Lamb 2002-08-30 04:48:48 UTC
Description of Problem:

up2date does not close fds for packages it is downloading. Default ulimit is
1024, so I think up2date will consistently fail to run if a system has that many
packages out of date. Particularly since this happens both with newly downloaded
files and ones already in /var/spool/up2date.

Version-Release number of selected component (if applicable):

up2date-2.57-1

How Reproducible:

Always.

Steps to Reproduce:
1. Run up2date with many updates to do.
2. Midway through the process, do a "lsof -p <PID> | less"

Actual Results:

There are lots and lots of open /var/spool/up2date/* files.

Expected Results:

Just the one it is working on is open.

Comment 1 Scott Lamb 2002-08-30 05:46:24 UTC
Created attachment 73884 [details]
up2date's 384 open fds

Comment 2 Adrian Likins 2002-08-31 02:33:42 UTC
hmm, indeed. should be fixed in 2.9.62

Comment 3 Scott Lamb 2002-09-07 18:15:05 UTC
Yep, works for me. (I checked 2.9.68.) Thanks.


Note You need to log in before you can comment on or make changes to this bug.