Bug 730477 - [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/ms2502_40hotmail_2ede at 0x93eec2c>
[abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError...
Status: CLOSED DUPLICATE of bug 691209
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
abrt_hash:2ae19c7af099b761556e456f18c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-13 08:59 EDT by Markus Schulze
Modified: 2011-11-20 09:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-20 09:36:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Markus Schulze 2011-08-13 08:59:35 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
comment:        No Internet connection while empathy was startet. Crash happens very often.
component:      telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         2.6.40-4.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        telepathy-butterfly-0.5.15-3.fc15
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/ms2502_40hotmail_2ede at 0x93eec2c>
time:           Sat Aug 13 13:41:06 2011
uid:            500
username:       schulze

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/ms2502_40hotmail_2ede at 0x93eec2c>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 425, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/ms2502_40hotmail_2ede at 0x93eec2c>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0x93ee74c>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/ms2502_40hotmail_2ede at 0x93eec2c>
Comment 1 Brian Pepple 2011-11-20 09:36:44 EST

*** This bug has been marked as a duplicate of bug 691209 ***

Note You need to log in before you can comment on or make changes to this bug.