Bug 730479 - SELinux is preventing /usr/bin/python from 'execute' accesses on the file /bin/ping.
Summary: SELinux is preventing /usr/bin/python from 'execute' accesses on the file /bi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: i386
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:4c29e45b9bb...
: 730484 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-13 14:09 UTC by Heiko Adams
Modified: 2011-10-06 00:02 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.9.16-39.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-06 00:02:29 UTC


Attachments (Terms of Use)

Description Heiko Adams 2011-08-13 14:09:00 UTC
SELinux is preventing /usr/bin/python from 'execute' accesses on the file /bin/ping.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that python should be allowed execute access on the ping file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wicd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:object_r:ping_exec_t:s0
Target Objects                /bin/ping [ file ]
Source                        wicd
Source Path                   /usr/bin/python
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           python-2.7.1-7.fc15
Target RPM Packages           iputils-20101006-7.fc15
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40.1-1.fc15.i686.PAE #1 SMP
                              Sat Aug 6 06:02:30 UTC 2011 i686 i686
Alert Count                   1
First Seen                    Sa 13 Aug 2011 16:07:37 CEST
Last Seen                     Sa 13 Aug 2011 16:07:37 CEST
Local ID                      070dc549-1bb2-411d-b5d3-ff3568760502

Raw Audit Messages
type=AVC msg=audit(1313244457.695:86): avc:  denied  { execute } for  pid=1947 comm="wicd" name="ping" dev=dm-1 ino=2233715 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:ping_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1313244457.695:86): arch=i386 syscall=execve success=no exit=EACCES a0=b6b00768 a1=b6b02850 a2=bff4df54 a3=7 items=0 ppid=1721 pid=1947 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=wicd exe=/usr/bin/python subj=system_u:system_r:NetworkManager_t:s0 key=(null)

Hash: wicd,NetworkManager_t,ping_exec_t,file,execute

audit2allow

#============= NetworkManager_t ==============
allow NetworkManager_t ping_exec_t:file execute;

audit2allow -R

#============= NetworkManager_t ==============
allow NetworkManager_t ping_exec_t:file execute;

Comment 1 Daniel Walsh 2011-08-15 10:39:45 UTC
*** Bug 730484 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2011-08-15 10:44:05 UTC
Why is wicd executing the ping command.

Comment 3 Heiko Adams 2011-08-15 11:09:25 UTC
AFAIR there's an option to ping static gateways to verify connection status.

Comment 4 Daniel Walsh 2011-08-15 11:30:29 UTC
Miroslav lets add

optional_policy(`
	netutils_domtrans_ping(NetworkManager_t)
')

Comment 5 Daniel Walsh 2011-08-15 11:33:01 UTC
Actually lets just do.

netutils_exec_ping

Comment 6 Miroslav Grepl 2011-08-22 06:46:25 UTC
Fixed in selinux-policy-3.9.16-39.fc15

Comment 7 Fedora Update System 2011-09-08 08:12:02 UTC
selinux-policy-3.9.16-39.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-39.fc15

Comment 8 Fedora Update System 2011-09-09 05:28:12 UTC
Package selinux-policy-3.9.16-39.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-39.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-39.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-10-06 00:02:29 UTC
selinux-policy-3.9.16-39.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.