This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 73054 - mozilla can crash metacity
mozilla can crash metacity
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xft (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
http://1stline.com.br
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-30 03:01 EDT by Alexandre Oliva
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 13:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-08-30 03:01:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
Browsing to http://1stline.com.br in mozilla causes metacity to crash.  It
restarts, but if mozilla is on a different virtual desktop, whenever you switch
to that desktop again, it crashes.  I haven't had the guts to see what happens
if mozilla is in the first virtual terminal.

Version-Release number of selected component (if applicable):
metacity-2.4.0.92-4
mozilla-1.0.1-22

How reproducible:
Always

Steps to Reproduce:
1.Browse to http://1stline.com.br in mozilla
	

Actual Results:  metacity crashes

Expected Results:  erhm...

Additional info:
Comment 1 Havoc Pennington 2002-08-30 18:20:41 EDT
Problem is Xft crashing on huge strings
Comment 2 Owen Taylor 2003-01-14 16:27:02 EST
There might still be a problem with Xft and long strings, but the
length of the loong string is much longer, and I couldn't crash
metacity by setting enormous titles with gtk_window_set_title(),
which is what Mozilla uses.

Moving off target, since it is basically an item for upstream.
Comment 3 Owen Taylor 2003-08-28 13:00:32 EDT
Actually, the problem with much longer strings never actually existed 
for metacity. Pango never feeds Xft more than 1024 glyphs at a time.

I've filed it as:

 http://www.fontconfig.org/cgi-bin/bugzilla/show_bug.cgi?id=108

however, just so that the issue doesn't get forgotten.

Note You need to log in before you can comment on or make changes to this bug.