Bug 730606 - The fuzzies entries from an imported PO file appear as translated in the zanata workspace
The fuzzies entries from an imported PO file appear as translated in the zana...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
1.3
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-15 00:43 EDT by Manuel Ospina
Modified: 2015-11-09 19:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 00:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manuel Ospina 2011-08-15 00:43:49 EDT
Description of problem: 
The fuzzies entries from an imported PO file appear as translated in the zanata workspace. I used the python client

Version-Release number of selected component (if applicable): 1.3


How reproducible: Always


Steps to Reproduce:
1. Go to a project with existing PO files. The project should have some Fuzzy entries.
2. Run $zanata publish push --import-po
3. Go to project in the zanata instance
  
Actual results:
The entry that appear as fuzzy in the local PO file, now appear as translated in the zanata workspace!


Expected results:
It should appear as Fuzzy in the zanata workspace. The fuzzy should be kept.


Additional info:
Comment 1 James Ni 2011-08-15 01:36:40 EDT
I think this bug is same to "Bug 728821 - Fuzzy strings are not shown on web interface after uploading", sorry, it's my fault, when i parsing the po file to json, i didn't consider the fuzzy entry (processing "#, fuzzy" flag in each entry), i will add this processing and fix it in soon.
Comment 2 James Ni 2011-08-15 01:40:36 EDT
*** Bug 728821 has been marked as a duplicate of this bug. ***
Comment 3 James Ni 2011-08-16 04:58:18 EDT
I have modified source code of python client to fix this issue, changes in
commit 8f87e1. 
The fuzzy messages will be imported and displayed as Fuzzy in the zanata workspace. I have test and verify this on my locale machine.

There is one make me confused. I compare the status between zanata instance on
my locale machine with 'publican lang_stats', The number is different. I am not
sure which one is correct, or both is correct, just because using different
count method.
Comment 4 Ding-Yi Chen 2011-10-16 21:05:41 EDT
VERIFIED with zanata-python-client-1.3.1-1.el5

and Zanata version 1.4.2-SNAPSHOT (20111014-1722

Note You need to log in before you can comment on or make changes to this bug.