Bug 73064 - when USB mouse in use, PS/2 mouse motion halts keyboard input
Summary: when USB mouse in use, PS/2 mouse motion halts keyboard input
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: null
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Preston Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-30 10:25 UTC by Barry K. Nathan
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-13 06:32:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "rpm -qa" (14.34 KB, text/plain)
2002-08-30 10:26 UTC, Barry K. Nathan
no flags Details

Description Barry K. Nathan 2002-08-30 10:25:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
When a USB mouse is plugged in and configured, any PS/2 mouse motion kills the
keyboard dead until the next reboot. (My recollection is that if you're at a
text console when you move that PS/2 pointing device, the only way to reboot is
via SSH. To put it lightly, this could be a problem.)

Version-Release number of selected component (if applicable):
See attached rpm -qa output.

How reproducible:
Always

Steps to Reproduce:
On my Dell Inspiron 5000e:

1. Install (null), with machine removed from docking station.
2. Update with latest packages from both rawhide & RHN.
3. Machine should be working with PS/2 internal trackpad & keyboard successfully.
4. Plug USB mouse and PS/2 keyboard into docking station. Make sure docking
station does not have a PS/2 mouse or USB keyboard plugged in.
5. Shut the computer down if it's on.
6. Dock the computer.
7. Turn the computer on.
8. Choose the latest kernel.
9. Choose all the kudzu defaults like a mindless drone.
10. Wait for GDM to appear.
11. Log in.
12. Notice that you can move USB mouse.
13. Start a terminal, and type some stuff. Notice how this works.
14. Touch your PS/2 touchpad.
15. Try typing. Notice the keyboard stopped working.
16. Use the menus to shut down.
17. During shutdown, notice log messages on the screen such as these:
oops() invoked from gpm.c(164)
/dev/tty0: Input/output error

To reproduce again:
18. Undock computer.
19. Repeat steps 7 through 10.
20. Repeat steps 5 through 20 as many times as desired.

Bonus: If you reboot instead of shutting down in step 16, the keyboard may act
weird on the next boot.

If you don't have a docking station, pretend that your USB mouse is a docking
station. If you don't have a PS/2 touchpad, pretend your PS/2 mouse is a PS/2
touchpad and be really careful. :) [NB: I haven't tried either of these
variations yet.]

Actual Results:  Motion on PS/2 pointing device kills keyboard input.

Expected Results:  Ideally, the PS/2 touchpad and the USB mouse should both be
usable simultaneously. At a minimum, the PS/2 touchpad should be ignored but the
keyboard should keep working.

Additional info:

I have no real idea which component is guilty so I'll just attach rpm -qa output.

Comment 1 Barry K. Nathan 2002-08-30 10:26:16 UTC
Created attachment 73932 [details]
Output of "rpm -qa"

Comment 2 Damien 2002-09-13 06:32:03 UTC
This bug may be the same as bug 70696.

Comment 3 Barry K. Nathan 2002-10-06 00:39:19 UTC
Closing -- cannot reproduce in 8.0.


Note You need to log in before you can comment on or make changes to this bug.