Bug 730743 - ran a yum update on this machine and error
ran a yum update on this machine and error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.8
i686 Linux
unspecified Severity low
: rc
: ---
Assigned To: packaging-team-maint
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-15 11:18 EDT by flo
Modified: 2014-01-21 01:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 16:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description flo 2011-08-15 11:18:48 EDT
Description of problem:
i did this as root:
yum --exclude=kernel* --exclude=lockss* update
and the problem:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xen-libs is needed by (installed) xen-3.0.3-80.el5_3.3.i386
Complete!

Version-Release number of selected component (if applicable):
Linux capa.irss.unc.edu 2.6.18-194.26.1.el5 #1 SMP Fri Oct 29 14:21:22 EDT 2010 i686 i686 i386 GNU/Linux


How reproducible:
yum --exclude=kernel* --exclude=lockss* update


Steps to Reproduce:
1. login as root
2. run: yum --exclude=kernel* --exclude=lockss* update
3. error return
ERROR with rpm_check_debug vs depsolve:
xen-libs is needed by (installed) xen-3.0.3-80.el5_3.3.i386
  
Actual results:


Expected results:
xen-lib installed

Additional info:
Comment 1 James Antill 2013-03-11 16:32:46 EDT
 This is usually a problem because xen was installed from the CD, but you don't have the channels with the latest versions of xen/xen-libs.

 If that isn't the case try running:

rpm -Va --nofiles

Note You need to log in before you can comment on or make changes to this bug.