Bug 730746 - dovecot does not assign stderr to /dev/null
Summary: dovecot does not assign stderr to /dev/null
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dovecot
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 15:36 UTC by Nate Straz
Modified: 2015-07-22 06:56 UTC (History)
4 users (show)

Fixed In Version: dovecot-2.0.9-17.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:56:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1348 normal SHIPPED_LIVE dovecot bug fix and enhancement update 2015-07-20 17:59:48 UTC

Description Nate Straz 2011-08-15 15:36:29 UTC
Description of problem:

When dovecot daemonizes it does not assign stderr to /dev/null like it does for stdin and stdout, or like other daemons do.  This causes tools which monitor stderr for output to hang when starting dovecot.

Version-Release number of selected component (if applicable):
dovecot-2.0.9-2.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:

# service dovecot status
dovecot is stopped
# lsof -p $$ | grep 2u
bash    30156 root    2u   CHR  136,0      0t0       3 /dev/pts/0
# service dovecot start
Starting Dovecot Imap:                                     [  OK  ]
# lsof -p `pidof dovecot` | grep '/dev/pts/0'
dovecot 1646 root    2u   CHR              136,0      0t0       3 /dev/pts/0

  
Actual results:
dovecot does not dup stderr to /dev/null

Expected results:
dovecot does dup stderr to /dev/null

Additional info:

I found a patch submitted in the dovecot mailing list which should fix this issue.
http://www.mailinglistarchive.com/html/dovecot@dovecot.org/2011-01/msg00176.html

Comment 2 RHEL Product and Program Management 2011-08-15 16:08:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Michal Hlavinka 2011-08-16 10:40:33 UTC
reproducible

Comment 6 gulikoza 2012-08-11 17:20:36 UTC
A we have been hit by this same bug (running a custom HA script which starts the required services and writes the stderr log at the same time) I'll write here instead of opening a new report.
We have patched our dovecot with the official hg-patch found here: http://hg.dovecot.org/dovecot-2.0/rev/08e4280e5bfd and it works well. The patch that OP posted has a followup post (IIRC) that states that it is not entirely correct.

Comment 10 errata-xmlrpc 2015-07-22 06:56:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1348.html


Note You need to log in before you can comment on or make changes to this bug.