Bug 730749 - problem with /distribution/virt/install workaround.
Summary: problem with /distribution/virt/install workaround.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: tests
Version: 0.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: Gurhan Ozen
QA Contact: Gurhan Ozen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 16:00 UTC by Gurhan Ozen
Modified: 2013-11-04 02:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-29 16:37:57 UTC


Attachments (Terms of Use)

Description Gurhan Ozen 2011-08-15 16:00:15 UTC
Description of problem:
From the email:

"
Hello,

I just noticed that our old virt reserving xml failed at
/distribution/virt/install:

https://beaker.engineering.redhat.com/jobs/119202

And if I try to comment out the workaround for bz729608, it works again,
at least not at "ERROR (cli:283) Need to pass size for each disk":

https://beaker.engineering.redhat.com/jobs/119253

I notice that though we had already passed '--file ...' to the script,
it still added another '--file ...' in the command for virt-install. I
cannot figure out why is this. I guess maybe this line:

 echo ${CMDLINE} | awk '{rc=0; for(i=1;i<=NF;i++) { if ( $i ~ /--disk*/ # || $i ~ /--file=/ || $i == "--file" ) rc+=1; } exit rc }'

should be written as

 echo ${CMDLINE} | awk 'BEGIN {rc=0} ; { for(i=1;i<=NF;i++) { if ( $i ~ /--disk*/ || $i ~ /--file=/ || $i == "--file" ) rc+=1 }}; END { exit rc; }'

Because it looks like the CMDLINE was echoed as multi-lines.

Please have a look. Thanks in advance.
"

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Gurhan Ozen 2011-10-29 16:16:31 UTC
fixed long time ago.


Note You need to log in before you can comment on or make changes to this bug.