Bug 730754 - A provider with multiple products does not render them correctly.
Summary: A provider with multiple products does not render them correctly.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Jason E. Rist
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-15 16:28 UTC by Corey Welton
Modified: 2013-08-16 18:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:52:29 UTC


Attachments (Terms of Use)
Screenshot from Firefox (33.48 KB, image/png)
2011-08-15 16:29 UTC, Corey Welton
no flags Details

Description Corey Welton 2011-08-15 16:28:25 UTC
Description of problem:
If you create a provider that has multiple products, the products & repositories view renders incorrectly - it seems to run all the products in one line or something.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Create a new provider, "Google"
2. Create a new Product, "Google Chrome"
3. Create a new repository under Google Chrome, "chrome - x86_64", using the URL 
"http://dl.google.com/linux/chrome/rpm/stable/x86_64"
4. Create a new Product, "Google Talk Plugin"
5. Create a new repository under Google Talk Plugin, "talk plugin - x86_64", using the URL http://dl.google.com/linux/talkplugin/rpm/stable/x86_64
6. Navigate back to the Products & Repositories view for 'Google'

Actual results:
The two products seem to run on from one line, and are not notated correctly.

Expected results:
Correct rendering.

Additional info:
See forthcoming screenshot.  This appears in Both Chrome and Firefox.

Comment 1 Corey Welton 2011-08-15 16:29:34 UTC
Created attachment 518286 [details]
Screenshot from Firefox

Comment 2 Jason E. Rist 2011-08-18 21:15:56 UTC
CSS alignment. Fixed in: 7fcd895d3f98cf43680cd38e378a49c408b96dd2

Comment 3 Corey Welton 2011-09-22 14:37:12 UTC
QA Verified

Comment 6 Mike McCune 2013-08-16 18:23:06 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.