Bug 73079 - dhcpctl man-page misformated
dhcpctl man-page misformated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: dhcp (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 10:08 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 16:04:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against dhcpctl.3 (759 bytes, patch)
2002-08-30 20:01 EDT, Enrico Scholz
no flags Details | Diff
Patch against dhcpctl.3 of dhcp-3.0pl1-23 (512 bytes, patch)
2003-02-25 07:58 EST, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2002-08-30 10:08:56 EDT
Description of Problem:

The dhcpctl(3) manpage misformats normal text. This seems to be caused by the
dhcp-3.0pl1-dhcpctlman-69731.patch where e.g. '.Fd' nroff sequences are replaced
with '\fB' (there are other substitutions also).

When using the original sequences all things are fine.


Version-Release number of selected component (if applicable):

dhcp-devel-3.0pl1-9
groff-1.18-5
man-1.5j-9


How Reproducible:


Steps to Reproduce:
1. 'man 3 dhcpctl'
2. go to the 'DESCRIPTION' section


Actual Results:

text is bold


Expected Results:

text is not bold
Comment 1 Elliot Lee 2002-08-30 14:02:59 EDT
My knowledge of *roff language is certainly lacking. I made the changes to make some 
warnings produced by nroff go away. I'd be happy to take any patches to get correct, 
warning-free behaviour.
Comment 2 Enrico Scholz 2002-08-30 20:01:07 EDT
After studying the groff_mdoc(7) manpage I can attach a patch against dhcpctl.3.
I do not know if '.Em' (emphasizing) is the correct attribute for the URL and
the progname, but I could not find a better alternative for the previously used
'.B' (bold).
Comment 3 Enrico Scholz 2002-08-30 20:01:57 EDT
Created attachment 74124 [details]
Patch against dhcpctl.3
Comment 4 Daniel Walsh 2003-01-06 13:01:43 EST
Fixed in dhcp-3_0pl1-12
Comment 5 Enrico Scholz 2003-02-25 07:58:53 EST
Created attachment 90348 [details]
Patch against dhcpctl.3 of dhcp-3.0pl1-23

I still get:

| $ man 3 dhcpctl >/dev/null 
| Usage: .Fd function_declaration -- Fd is not callable (#28)
| Not a \-mdoc command: .SH (#465)

and parts of the manpage are misformated (the AUTHOR heading is missing). The
attached patch fixes this.
Comment 6 Daniel Walsh 2003-03-04 11:49:12 EST
fixed in 3.0pl1-24

Note You need to log in before you can comment on or make changes to this bug.