Bug 730798 - Anaconda unexpectedly erases preformatted install partition content
Summary: Anaconda unexpectedly erases preformatted install partition content
Keywords:
Status: CLOSED DUPLICATE of bug 629311
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 19:34 UTC by Mae Marcus
Modified: 2011-08-16 14:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-16 14:09:22 UTC


Attachments (Terms of Use)

Description Mae Marcus 2011-08-15 19:34:35 UTC
Description of problem:

Anaconda has an ability to select custom partitions layout. Among other options, it can install system on the previously formatted partition (i.e. formatted before outside anaconda). In this context is is *expected* that files that may happen to be on this partition will be either rewritten or conserved after install. Apparently, they all are deleted, that is potentially a data loss problem.

Version-Release number of selected component (if applicable):

15

How reproducible:

Steps to Reproduce:
1. Start installing Fedora 15 from live usb
2. For partitions select custom layout and select preformatted partition for "/"
3. Run installation
  
Actual results:

Anaconda delivers clean system install on the partition with "/".

Expected results:

Anaconda should conserve files previously located on "/", as soon as it was not asked to format the partition.

Comment 1 Chris Lumens 2011-08-16 14:09:22 UTC

*** This bug has been marked as a duplicate of bug 629311 ***


Note You need to log in before you can comment on or make changes to this bug.