Bug 730802 - BUG: sleeping function called from invalid context at arch/x86/mm/fault.c:1087
Summary: BUG: sleeping function called from invalid context at arch/x86/mm/fault.c:1087
Keywords:
Status: CLOSED DUPLICATE of bug 708202
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 19:44 UTC by bugfinder
Modified: 2011-08-15 21:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-15 21:55:06 UTC


Attachments (Terms of Use)
dmesg output (12.51 KB, text/plain)
2011-08-15 19:44 UTC, bugfinder
no flags Details

Description bugfinder 2011-08-15 19:44:51 UTC
Created attachment 518320 [details]
dmesg output

Kernel - 2.6.38.6-26.rc1.fc15.i686

This doesn't happen always but it did the last two times it tried to go to sleep. It seemed to hang but capslock worked on keyboard. I managed to SSH in from another system and run dmesg. The output is attached.

The latest kernel causes the system to freeze completely (another bug has been filed against it) so I can't upgrade either.

Comment 1 bugfinder 2011-08-15 21:02:13 UTC
The system froze a few hours later.

Comment 2 Dave Jones 2011-08-15 21:55:06 UTC
That particular symptom seemed to affect a number of people in 2.6.38, (search for fault.c:1087, and you'll see a dozen or so different traces)

This one in particular looks like 708202 which I'll dupe it against.

I'm optimistic that this has been fixed in 2.6.40, so we'll focus on getting your other bug fixed asap.

thanks.

*** This bug has been marked as a duplicate of bug 708202 ***


Note You need to log in before you can comment on or make changes to this bug.