Bug 73081 - up2date can get server too busy error mid-session
Summary: up2date can get server too busy error mid-session
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-30 14:16 UTC by Michael Young
Modified: 2015-01-08 00:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 12:55:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error messages from up2date client dying (1.73 KB, text/plain)
2003-05-17 20:59 UTC, Robert M. Riches Jr.
no flags Details

Description Michael Young 2002-08-30 14:16:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; SunOS 5.9 sun4u)

Description of problem:
I was downloading lots of upgrades with a free rhn account using up2date (gui
interface). Halfway through downloading the packages, the standard error message
saying the server was too busy for free users appeared in the terminal up2date
was run from. The only option was to press the cancel button on the GUI.
This was with up2date-2.9.55-2.

Steps to Reproduce:
1. up2date lots of packages on a free account.
	

Expected Results:  A session should last until all packages are installed, or at
least it should fail more gracefully.

Comment 1 Adrian Likins 2002-08-31 00:01:11 UTC
yes, investigating...

server guys claim it shouldnt ever do this. They are wrong
of course, so trying to find a workaround in the client
at the moment.

Comment 2 Need Real Name 2002-08-31 17:50:51 UTC
I'm not sure if this is the same bug or not, but I experienced something very
similar.  About 2/3 of the way through an extensive update (100's of MB), the
downloads just stopped.  I eventually exited the up2date gui via the 'cancel'
button.  While I didn't get a std error msg about the server being too busy,
there was a python traceback left on the terminal, which included the text for
such a msg:

[root@slick grover]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1448, in doRetrieval
    self.setRetrievalProgress)
  File "/usr/share/rhn/up2date_client/up2date.py", line 255, in getPackage
    buffer = rpcServer.doCall(rpmSource.psc.packageSource.getPackage, pkg,
msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 134, in doCall
    up2dateAuth.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 110, in updateLoginInfo
    loginInfo = login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 99, in login
    loginInfo = rpcServer.doCall(server.up2date.login, systemId)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 123, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 133, in request
    return self.parse_response(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 153, in
parse_response
    return u.close()
  File "/usr/lib/python2.2/xmlrpclib.py", line 571, in close
    raise apply(Fault, (), self._stack[0])
xmlrpclib.Fault: <Fault -51: '\nError Message:\n    Free service limited due to
high load, please try again later (server 1001140430)\nError Class Code:
51\nError Class Info: \n
  Due to extremely high traffic, access to Red Hat Network is currently  \n    
limited to subscription customers.  Please try again later.  If you \n     would
like to become a subscription customer, go to \n    
https://rhn.redhat.com/preview/priority_service.pxt for
more information.\nExplanation: \n     An error has occurred while processing
your request. If this problem\n     persists please submit a bug report to
rhn-help@redhat.com.\n
If you choose to submit the bug report, please be sure to include\n     details
of what you were trying to do when this error occurred and\n     details on how
to reproduce this problem.\n'>

Comment 3 Michael Young 2002-09-01 13:44:49 UTC
Grover: Yes I think it is the same bug.

Comment 4 Robert M. Riches Jr. 2003-05-17 20:56:52 UTC
This _really_ leaves a bad taste in the mouth of a customer
who paid for a boxed set.  In case it might be of some use,
I will attach my error messages.

In my case, the up2date client process is hung.  This
leaves me wondering whether killing it will corrupt the RPM
DB, etc.  Maybe I should listen to the friend of mine who
highly recommends Mandrake.  :-(


Comment 5 Robert M. Riches Jr. 2003-05-17 20:59:34 UTC
Created attachment 91762 [details]
error messages from up2date client dying

This is the stdout/stderr I got when up2date died, with
the client process hung.

Comment 6 Michael Young 2004-01-12 12:55:50 UTC
Closing as 8.0 has expired, and the issue isn't relevant to FC1.


Note You need to log in before you can comment on or make changes to this bug.