Bug 730824 - run-parts needs changed to 'ls'
Summary: run-parts needs changed to 'ls'
Keywords:
Status: CLOSED DUPLICATE of bug 705822
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: logcheck
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 20:50 UTC by glshank
Modified: 2011-08-16 06:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-16 06:38:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 705822 None None None Never

Internal Links: 705822

Description glshank 2011-08-15 20:50:50 UTC
Description of problem:
Filters are not being read because run-parts is being used on the directories. I guess Debian has a --list option to run-parts but RedHat does not.

Version-Release number of selected component (if applicable):
logcheck-1.3.13-3.el5

How reproducible:
All the time

Steps to Reproduce:
1.Install logwatch
2.Run logwatch
3.Notice that nothing is filtered out
  
Actual results:
Nothing is filtered out

Expected results:
Filters should be applied

Additional info:
I fixed it by changing run-parts to ls

218c218
<       for rulefile in $(ls "$dir"); do
---
>       for rulefile in $(run-parts "$dir"); do

Comment 1 Matthias Runge 2011-08-16 06:38:52 UTC

*** This bug has been marked as a duplicate of bug 705822 ***


Note You need to log in before you can comment on or make changes to this bug.