Bug 730829 - panic in __btrfs_setxattr+0xd8/0xf0 [btrfs] while installing RHEL 6.2 to x86_64 system with 2 btrfs partitions configured
Summary: panic in __btrfs_setxattr+0xd8/0xf0 [btrfs] while installing RHEL 6.2 to x86...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: Josef Bacik
QA Contact: Filesystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 20:53 UTC by Mike Gahagan
Modified: 2013-03-04 00:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-11 17:17:12 UTC


Attachments (Terms of Use)

Description Mike Gahagan 2011-08-15 20:53:24 UTC
Description of problem:
------------[ cut here ]------------ 
kernel BUG at fs/btrfs/xattr.c:169! 
invalid opcode: 0000 [#1] SMP  
last sysfs file: /sys/devices/pci0000:00/0000:00:1f.2/host0/target0:0:0/0:0:0:0/block/sda/removable 
CPU 0  
Modules linked in: btrfs(T) zlib_deflate lzo_decompress lzo_compress libcrc32c ext3 jbd fcoe libfcoe libfc scsi_transport_fc scsi_tgt xts lrw gf128mul sha256_generic cbc dm_crypt dm_round_robin dm_multipath dm_snapshot dm_mirror dm_region_hash dm_log dm_zero dm_mod linear raid10 raid456 async_raid6_recov async_pq raid6_pq async_xor xor async_memcpy async_tx raid1 raid0 ext2 mbcache nfs lockd fscache(T) nfs_acl auth_rpcgss sunrpc sg sd_mod crc_t10dif sr_mod cdrom nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi video output pata_acpi ata_generic ata_piix ahci tg3 wmi iscsi_ibft iscsi_boot_sysfs pcspkr edd floppy mlx4_ib mlx4_en mlx4_core ib_ipoib ib_cm ib_sa ib_mad ib_core ipv6 iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi squashfs cramfs [last unloaded: scsi_wait_scan] 
 
Pid: 673, comm: anaconda Tainted: G           ---------------- T 2.6.32-184.el6.x86_64 #1 Hewlett-Packard hp workstation xw4200/0914h 
RIP: 0010:[<ffffffffa0675178>]  [<ffffffffa0675178>] __btrfs_setxattr+0xd8/0xf0 [btrfs] 
RSP: 0018:ffff88001a875c98  EFLAGS: 00010282 
RAX: 00000000fffffffe RBX: ffff88000f7f3d90 RCX: ffff88001a874000 
RDX: 000000000000000f RSI: ffff8800165e3910 RDI: 0000000000000282 
RBP: ffff88001a875cd8 R08: 0000000000000001 R09: 0000000000000001 
R10: 0000000000000000 R11: 0000000000000001 R12: ffff88000ac5b000 
R13: ffff8800140b4120 R14: 00000000fffffffe R15: 000000000000001b 
FS:  00007f7e8a6f1700(0000) GS:ffff880002200000(0000) knlGS:0000000000000000 
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033 
CR2: 000000000a88e628 CR3: 0000000019085000 CR4: 00000000000006f0 
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000 
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400 
Process anaconda (pid: 673, threadinfo ffff88001a874000, task ffff88001941f4c0) 
Stack: 
 ffff880000000000 000000000000001b ffff880006d726c0 ffff88001a875de8 
<0> ffff88001a875de8 ffff88000f7f3d90 000000000000001b 0000000000000000 
<0> ffff88001a875d18 ffffffffa06752d7 0000000000000000 ffff880006d726c0 
Call Trace: 
 [<ffffffffa06752d7>] btrfs_setxattr+0xb7/0xc0 [btrfs] 
 [<ffffffff8119832e>] __vfs_setxattr_noperm+0x4e/0x160 
 [<ffffffff811984fc>] vfs_setxattr+0xbc/0xc0 
 [<ffffffff811985d0>] setxattr+0xd0/0x150 
 [<ffffffff81180fb1>] ? path_put+0x31/0x40 
 [<ffffffff811809c5>] ? putname+0x35/0x50 
 [<ffffffff81183372>] ? user_path_at+0x62/0xa0 
 [<ffffffff81175c01>] ? __fput+0x1a1/0x210 
 [<ffffffff811987d5>] sys_lsetxattr+0xa5/0xc0 
 [<ffffffff8100b0b2>] system_call_fastpath+0x16/0x1b 
Code: eb 85 90 e8 fb 54 a2 e0 4c 89 e6 48 89 93 98 00 00 00 48 89 83 90 00 00 00 48 89 da 4c 89 ef e8 3f 74 fe ff 85 c0 41 89 c6 74 ca <0f> 0b eb fe 41 89 c6 90 e9 4f ff ff ff 66 66 2e 0f 1f 84 00 00  
RIP  [<ffffffffa0675178>] __btrfs_setxattr+0xd8/0xf0 [btrfs] 
 RSP <ffff88001a875c98> 
---[ end trace 7cac3fc8faca9d01 ]--- 


Version-Release number of selected component (if applicable):
2.6.32-184.el6.x86_64
0812.n.1 tree

How reproducible:
so far only once

Steps to Reproduce:
1.install to x86_64 bare metal consisting of 2 btrfs data partitions 
2.
3.
  
Actual results:


Expected results:
installation completes sucessfully, same job worked fine with 6.1

Additional info:
http://lab2.rhts.eng.bos.redhat.com/beaker/logs/recipes/247594//console.log
https://beaker.engineering.redhat.com/jobs/120379

Comment 1 Mike Gahagan 2011-08-15 20:58:20 UTC
This is reproduceable at least 2 out of 2 times...

Panic occurs during package installation, apperantly something the filesystem package is doing is causing it when it is installed.

Installing filesystem-2.4.30-3.el6.x86_64 (0 Bytes) 
The basic directory layout for a Linux system 

https://beaker.engineering.redhat.com/jobs/120379

Comment 2 Josef Bacik 2011-08-17 13:56:04 UTC
Well that's just weird.  I can't reproduce on a normally booted system unfortunately, so I guess I'll have to figure out how to give anaconda a custom kernel, joy.

Comment 3 Mike Gahagan 2011-08-23 18:33:39 UTC
I managed to get a successful install on an x86_64 box with the 0822.5 tree

https://beaker.engineering.redhat.com/jobs/123151

i386 and ppc64 both still seem to hang during formatting the first btrfs partition as before though.

Comment 6 RHEL Product and Program Management 2011-10-07 15:44:42 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Mike Gahagan 2011-10-11 17:17:12 UTC
I've tried several other test runs with btrfs and was able to get the systems installed without seeing this panic so closing as currentrelase.


Note You need to log in before you can comment on or make changes to this bug.