Bug 730841 - Can't list environments in an Org
Summary: Can't list environments in an Org
Keywords:
Status: CLOSED DUPLICATE of bug 737591
Alias: None
Product: Katello
Classification: Retired
Component: Client
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 22:04 UTC by Mike McCune
Modified: 2011-09-14 08:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 08:13:03 UTC


Attachments (Terms of Use)

Description Mike McCune 2011-08-15 22:04:43 UTC
$ katello environment list --org=ACME_Corporation
---------------------------------------------------------------------------------------------------------------------------------
                                                        Environment List
---------------------------------------------------------------------------------------------------------------------------------

error: zero length field name in format (more in the log file)

Comment 1 Mike McCune 2011-08-15 22:04:59 UTC
Also there didn't appear to be anything in /var/log/katello/client.log

Comment 2 Lukas Zapletal 2011-08-16 12:22:39 UTC
$ kk  environment list --org=ACME_Corporation
-----------------------------------------------------------------------------------------------------------------------
                                                   Environment List

 Id   Name     Description   Org Id   Prior Id  
-----------------------------------------------------------------------------------------------------------------------
 1    Locker   None          1        None      


Could you paste a log from the rails server? The error message seems to be coming from rails.

Comment 3 Tomas Strachota 2011-09-14 08:13:03 UTC
It is a Python version problem. String's method 'format' allows to omit
position specifiers since 2.7. fixed in commit 
fdd2765219019f87c859279c581644c154b9548e

*** This bug has been marked as a duplicate of bug 737591 ***


Note You need to log in before you can comment on or make changes to this bug.