Bug 730853 - [Springdale] system freeze when screensaver puts monitor on standby (82865G chipset)
[Springdale] system freeze when screensaver puts monitor on standby (82865G c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
[cat:lockup]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-15 19:26 EDT by Samuel Sieb
Modified: 2012-03-14 22:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.42.9-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-10 16:50:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (32.53 KB, text/plain)
2011-08-15 19:26 EDT, Samuel Sieb
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 44505 None None None Never

  None (edit)
Description Samuel Sieb 2011-08-15 19:26:50 EDT
Created attachment 518372 [details]
Xorg log

Device:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Packages:
xorg-x11-drv-intel-2.15.0-5.fc15.i686
kernel-PAE-2.6.40-4.fc15.i686

Using i915 kernel driver and Gnome 3 in fallback mode (this chipset is not supported by gnome-shell).  There is no xorg.conf file and only a keyboard config file in xorg.conf.d.

I have not seen this problem happen when the monitor goes to standby on the gdm login screen, but that could be because I haven't tested it long enough.  I also don't know which mode of standby it is using.  The setting is the one accessed from the Screen module in System Settings for the Brightness timeout.

After a user is logged in, when the screensaver activates, the monitor is put to standby.  Occasionally when this happens, the computer completely freezes.  No network, no keyboard, no logs.  I can't see anything on the screen because the monitor is off and the keyboard lights aren't flashing.

After a long time of trying to reliably reproduce it, it appears to be random.
Comment 1 Samuel Sieb 2011-08-15 19:29:33 EDT
There are many of these computers in a school lab that have been running Fedora 13 and then 14 for nearly a year and I hadn't seen this problem until testing Fedora 15.
Comment 2 Matěj Cepl 2011-08-22 09:16:15 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* X server log file with backtraces (run as root
  zgrep Backtrace /var/log/Xorg.* /var/log/?dm/*
  to get a list of files we may be interested in)
* output of the dmesg command (if you cannot get it after the freeze,
  then at least anytime else), and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

I don't understand your comment about other computers in the school lab. Does it mean that all of them are suddenly broken with F15? If not, is there a possibility of a hardware problem?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Stuart D Gathman 2011-11-19 20:13:55 EST
Still broken on F16.  (And was reported on F14 as well.)  On F14, you can disable monitor standby to work around this problem.  This no longer seems to be possible in gnome on F16.  This makes gnome unusable on F16 (longest time before standby available is 1 hour).

Zgrep shows no Backtrace.

dmesg shows:
[ 2969.258003] [drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple times

repeatedly (and nothing else).

System crashes with nothing written to /var/log/messages either.  (And there is no ping, and no remote ssh to collect data.)  The monitor *does* turn off.  However, the entire system (not just the X server) is totally dead from that point.
Comment 4 Samuel Sieb 2011-11-19 23:58:18 EST
I'm very happy that someone else sees this.  Sorry for not responding earlier.  I was trying to get some more info, but I rarely have access to these computers as they are in a different city.  I couldn't get netconsole or serial console to work.

Yes, I meant that all the computers in the lab (all basically the same) started having this issue as soon as they were upgraded to F15.
Comment 5 Jean-François Fortin Tam 2011-11-26 11:03:31 EST
I can confirm what Stuart said here. Log files are useless as the kernel (or something else) freezes entirely the moment the screen turns off. Not even the keyboard LEDs will work. The problem is that this makes Fedora entirely unusable for the computers I maintain.
Comment 6 Jean-François Fortin Tam 2011-11-26 11:42:02 EST
Oh, and the version should be updated to F16.

Now, I have just found a very strange workaround: if you set the dconf key
org.gnome.desktop.session.idle-delay to 0, the screen will still enter power saving mode (after one minute), but it will not freeze the system. 

Not only is the "forced 1 minute screen blanking time" problematic, the computer will not automatically suspend anymore (only the screen will blank). Well, at least it doesn't freeze.
Comment 7 paul 2011-11-27 10:39:06 EST
I have exactly the same problem:-


No problem at login screen

When log in any user, the screen turn off as set.

The system hang, no log in message, nothing.

ACPI=off works but monitor type is not detected, resolution drops to ~1024

Same problem in F15, and not yet fixed in F16



Motherboard - ASRock P4i65g
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
Comment 8 paul 2011-11-27 20:09:50 EST
BTW, I tested a number of kernel parameters following some available discussions randomly on the web without knowing exactly what they means, but they can't fix the problem (except for acpi=off)

I am testing a number of other machines, like ASRock_H61M-U3S3 works but no SATA3 (USB3.0 not tested yet).

Kernel Parameters tested on ASRock P4i65g but Not working:-

acpi=noirq
noapci
nolapci
pci=noacpi
nolapic_timer
clocksource=acpi_pm nohz=off highres=off 
acpi=force irqpoll pci=use_crs
acpi_enforce_resources=lax 
pci=use_crs
acpi_sleep=old_ordering 
acpi_backlight=vendor
acpi_use_timer_override 
acpi_sleep=s3_bios
hpet=disable 


Thanks all.
Comment 9 paul 2011-11-28 01:57:07 EST
BTW, I tested a number of kernel parameters following some available discussions randomly on the web without knowing exactly what they means, but they can't fix the problem (except for acpi=off)

I am testing a number of other machines, like ASRock_H61M-U3S3 works but no SATA3 (USB3.0 not tested yet).

Kernel Parameters tested on ASRock P4i65g but Not working:-

acpi=noirq
noapci
nolapci
pci=noacpi
nolapic_timer
clocksource=acpi_pm nohz=off highres=off 
acpi=force irqpoll pci=use_crs
acpi_enforce_resources=lax 
pci=use_crs
acpi_sleep=old_ordering 
acpi_backlight=vendor
acpi_use_timer_override 
acpi_sleep=s3_bios
hpet=disable 


Thanks all.
Comment 10 Stuart D Gathman 2011-12-01 21:25:51 EST
This bears a mention in the release notes.  If you install F16, and try to update from the GUI, the screen will likely blank while you are off getting coffee - freezing the system so that you have to start over.
Comment 11 Stuart D Gathman 2011-12-02 21:46:02 EST
Found a workaround!  If you lock the screen, then when the screen blanks, it does not crash the system.  Also, the text consoles do not crash the system when the screen blanks.  I've set the screen lock time to be less than the screen blank time, which according to the above should avoid crashing.  Will let you know.
Comment 12 paul 2011-12-03 19:05:38 EST
Thanks.

I tested in F16.  I set lock screen to 1 min, turn off screen to say 3 min.

Nothing happen at 1 min, screen turned off at 3 min, ok.  The system is dead again, no keyboard, mouse, remote ssh not working - no route to host.


BTW, any similar formal report for F16, this is for F15 only.
Comment 13 Jean-François Fortin Tam 2011-12-03 20:50:20 EST
You should try my workaround in comment #6 instead.
Comment 14 Stuart D Gathman 2011-12-03 21:33:22 EST
I can confirm comment #12.  Although *manually* locking the screen prevents the lockup, the automatic "lock screen" does *not* work.  At all.  The screen does not lock (and the system still freezes when it tries to put monitor on standby).

This is a feature, not a bug.  It is designed to train you to always remember to lock your screen when leaving your workstation for any reason.  :-)

3D programs also do not work, like stellarium, supertuxkart, gnome3, etc.  I wonder if there is any connection?
Comment 15 paul 2011-12-04 03:40:25 EST
(In reply to comment #13)
> You should try my workaround in comment #6 instead.

Thanks.

I have checked man on dconf earlier but have not figured it out yet how it works.

Appreciate if there is more instructions.
Comment 16 Jean-François Fortin Tam 2011-12-04 09:05:21 EST
For editing dconf values, install dconf-editor.
Comment 17 paul 2011-12-04 19:41:22 EST
(In reply to comment #16)
> For editing dconf values, install dconf-editor.


Many Thanks.  Testing Now.


BTW, is Bug 710564 related?


https://bugzilla.redhat.com/show_bug.cgi?id=710564
Comment 18 paul 2011-12-04 20:26:19 EST
(In reply to comment #16)
> For editing dconf values, install dconf-editor.

It Works!


Seems problems are each user need to set it by themselves or otherwise any use can freeze the system very easily!

And the screen don't sleep anymore.



It seems weird that Fedora is not fixing this problem that make it not usable at all ?
Comment 19 Paul B. 2011-12-26 08:16:45 EST
  Oh the frustration!

  Just decided - Boxing Day Holiday and all - to "upgrade" from FC14 to FC16, has mostly been a pleasant task previously but this has been a nightmare!

  Machine is a HP/Compaq D530S with P4 2x at 3 GHz, Intel 82865G video.

  First frustration is this abomination called Gnome 3.  Indeed reported as being in fallback mode as the chipset is not supported by gnome-shell.  Now since this is a *very* stock standard chipset in a *very* popular (and reliable) workhorse business machine, this is in itself rather strange.

  First problem with the upgrade is the *complete* loss of desktop configuration - panel shortcuts, panel arrangement, pretty much everything.  Next problem is to realise that this "Gnome 3" is not configurable!  No panel properties, no auto-hide, simply no configuration options!  Started researching on this and it gets quite ludicrous - these things are *missing* from the GUI and only available by scripting add-ons which do not promise consistency.

  After bashing on this a while, I had had enough and went and did something else, only to return to a dead machine - lights on, no-one home.  A bit of testing reveals this to be the *old* "dies on monitor standby" fault.

  Not the same as bug 710564 though that does also sound just a little familiar.

  Note this fault is *old* - it was present in versions around FC 11, and apparently *fixed* in FC13 and 14 (IIRC)  - at least this was my experience.  Only manageable by disabling monitor standby but - Gnome 3 is *not configurable*!  I cannot presently confirm that it does *not* happen on the login screen, but on the earlier versions, it did not.  But of course, I never leave the machine logged out.

  This fault is *critical*.  It renders the operating system *unusable*, particularly on a Samba server machine.  This is not some minor annoyance.  And it is so far, not intermittent.
Comment 20 Paul B. 2011-12-26 08:49:33 EST
  Oh!

  dconf-editor

  I'll know overnight if the "idle" problem is sorted, but dconf-editor allows setting of the "hidden" parameters of the panels - size, orientation, auto-hide, and so on.  Soon I will figure out how to remove excess launchers.

  So relieved!  Looks like I will be able to use Gnome 3 after all, thanks to this thread.

  But why isn't dconf-editor already installed, and part of the "System Settings" tool?  (Not that it is hard to install - or use - or occupies any substantial space - just once you actually *know* what it is you need.)
Comment 21 Stuart D Gathman 2012-02-11 22:27:58 EST
Bad news!  With that latest updates, the workaround in comment#6 no longer works!!!!   I just verified that idle-delay is still set to 0 in dconf, but the system is now freezing again when putting the monitor on standby.  The nature of this bug is that there is no keyboard command to get a Kdump.  But it is very repeatable.  

Furthermore, since the kernel was updated, and not the intel driver, I think this has to be in the kernel mode set code.

Can someone with privilege please change this bug to version 16, and if they agree with my assessment, change the component to kernel?
Comment 22 Stuart D Gathman 2012-02-12 08:14:02 EST
I tried setting idle-delay to a very large number.  This prevented me from ever being "idle", but when I manually lock the screen, then FREEZE! an houir later.  So not a work around.  I tried setting the "nomodeset" kernel option.  This results in 640x480 video. Presumably I need to create an Xorg.conf - but the tool to generate this automatically is no longer present.  Rather than try Xconfigurator, I opted for going back a kernel.

The broken kernel version is kernel-3.2.3-2.fc16.i686

If no one changes the component, or at least the version, I will open a new bug on the kernel.
Comment 23 Stuart D Gathman 2012-02-12 13:00:44 EST
I just confirmed that kernel-3.2.2-1.fc16.i686 works (as far as the workaround in comment#6).  Kernel-3.2.3-2.fc16.i686 is broken (even worse than previous versions).
Comment 24 Stuart D Gathman 2012-02-12 15:52:19 EST
Kernel-3.2.5-3 is broken also.
Comment 25 Stuart D Gathman 2012-02-13 20:38:26 EST
I found a new workaround for the new kernels.  In addition to the idle-delay
workaround referenced in comment#6, set "Lock screen after" to "Screen turns off" in System Display settings.  I have no idea why this makes a difference.

I've tested on one system, and will test on this system when I get done tonight.
	

    Collapse All Comments
    Expand All Comments
Comment 26 Stuart D Gathman 2012-02-13 20:39:59 EST
Added bug#789728 to reference Fedora 16.
Comment 27 Stuart D Gathman 2012-02-14 21:36:01 EST
Additional workaround in comment#25 does *not* work on a 2 cpu system!  Only on a single cpu.  Interesting?  kernel-3.2.2 *does* work on a 2 cpu system (with workaround from comment#6), but later kernels all freeze.
Comment 28 Stuart D Gathman 2012-02-15 07:21:48 EST
I found a (sort of) workaround that is viable on 2 cpu systems: after locking
your screen, switch to a text console.  The text console does not freeze the
system when putting monitor on standby.  Hey - at least I can go out to the
store without shutting down my computer.
Comment 29 Adam Jackson 2012-03-02 12:31:04 EST
This appears to be:

https://bugs.freedesktop.org/show_bug.cgi?id=44505

I've pushed a patch for this to all kernel branches (F15 and up), should show up in the next round of updates.
Comment 30 Fedora Update System 2012-03-05 20:01:52 EST
kernel-2.6.42.9-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.42.9-2.fc15
Comment 31 Fedora Update System 2012-03-05 20:03:28 EST
kernel-3.2.9-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.9-2.fc16
Comment 32 Fedora Update System 2012-03-07 23:57:07 EST
Package kernel-3.2.9-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.2.9-2.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3350/kernel-3.2.9-2.fc16
then log in and leave karma (feedback).
Comment 33 Fedora Update System 2012-03-10 16:50:26 EST
kernel-3.2.9-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Fedora Update System 2012-03-14 22:31:22 EDT
kernel-2.6.42.9-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.