Bug 730862 - IOException: Partition(s) 1 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further
Summary: IOException: Partition(s) 1 on /dev/sdb have been written, but we have been u...
Keywords:
Status: CLOSED DUPLICATE of bug 729640
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a1c23a6c17aec303cb87bb891a9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 01:39 UTC by Adam Williamson
Modified: 2012-04-10 22:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 00:57:09 UTC


Attachments (Terms of Use)

Description Adam Williamson 2011-08-16 01:39:28 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         IOException: Partition(s) 1 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
time:           Mon Aug 15 18:38:23 2011
version:        16

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.5 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 213, in commit
:    return self.__disk.commit()
:  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 32, in new
:    ret = fn(*args, **kwds)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 263, in commit
:    self.partedDisk.commit()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 242, in create
:    self.commit()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 429, in execute
:    options=self.device.formatArgs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 383, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:IOException: Partition(s) 1 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.

Comment 1 Adam Williamson 2011-08-16 01:42:39 UTC
Booted live to Fedora 16 Alpha RC4 x86-64 desktop, written to a USB key with livecd-iso-to-disk. System has an SSD with my main install on it, and a 500GB Seagate hard disk for test purposes.

Chose 'advanced storage devices' at the first branch so I could leave the SSD out of the install. Made sure the USB stick and HD were checked, and SSD was not. Proceeded normally until partitioning stage, where I selected 'Use all space', and checked 'encrypt system' and 'review layout prior to install'. On reviewing the layout (just to ensure it wasn't going to wipe my SSD), saw everything was good, proceeded with no changes. Entered an encryption password and proceeded. After a bit of formatting and so forth, installer blew up with this error.

Just realized I mounted the HD prior to installation to check what was on it. This may be the cause of the error. Will reboot and retest without mounting the drive.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2011-08-16 02:01:36 UTC
yeah, after rebooting and *not* mounting the partition, it works. so this happens if you mount a target partition before install. I guess that makes it INVALID, but I'll leave it up to anaconda team.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Brian Lane 2011-08-17 00:57:09 UTC

*** This bug has been marked as a duplicate of bug 729640 ***

Comment 4 Adam Williamson 2012-04-10 22:56:42 UTC
I just hit this again with 17 Beta RC4, but I didn't intentionally mount anything before installing. I *did* accidentally change the sort order of hard disks in the diskssel screen before selecting the target disk for installation, but aside from that, it was a straight-through install test.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.