Bug 730868 - [abrt] ibus-1.3.99.20110419-13.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection is closed
[abrt] ibus-1.3.99.20110419-13.fc15: connection.py:630:call_blocking:DBusExce...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:45a4f6e03a1e661b861dabe426f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-15 22:40 EDT by Lucius Tran
Modified: 2011-09-13 01:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 06:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucius Tran 2011-08-15 22:40:17 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        
comment:        I dont known why it happened
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.40-4.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-13.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection is closed
time:           Tue Aug 16 09:24:40 2011
uid:            500

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection is closed
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/main.py", line 132, in <module>
:    main()
:  File "/usr/share/ibus/ui/gtk/main.py", line 127, in main
:    launch_panel(replace)
:  File "/usr/share/ibus/ui/gtk/main.py", line 94, in launch_panel
:    UIApplication(replace).run()
:  File "/usr/share/ibus/ui/gtk/main.py", line 43, in __init__
:    self.__bus = ibus.Bus()
:  File "/usr/lib/python2.7/site-packages/ibus/bus.py", line 65, in __init__
:    self.__unique_name = self.hello()
:  File "/usr/lib/python2.7/site-packages/ibus/bus.py", line 103, in hello
:    return self.__dbus.Hello()
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 68, in __call__
:    return self._proxy_method(*args, **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Disconnected: Connection is closed
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x928635c>
:args: ()
:utf8_strings: False
:bus_name: 'org.freedesktop.DBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/freedesktop/DBus'
:timeout: -1.0
:signature: None
:dbus_interface: 'org.freedesktop.DBus'
:message: <dbus.lowlevel.MethodCallMessage object at 0x920b710>
:method: 'Hello'
Comment 1 fujiwara 2011-08-16 21:30:25 EDT
Are you still able to reproduce your problem?
I cannot reproduce your problem.

It seems your problem is the basical dbus connection is failed.
Comment 2 Lucius Tran 2011-08-16 21:51:09 EDT
Sorry, I don't know how to reproduce it :P
Comment 3 fujiwara 2011-09-12 06:06:28 EDT
I think this won't be reproduced with the latest ibus:
# yum install ibus
Comment 4 Lucius Tran 2011-09-13 01:19:33 EDT
Me either. I have upgraded ibus to latest version and it's fine.
Thank you

Note You need to log in before you can comment on or make changes to this bug.