Bug 73087 - Ridiciously long message in rhn-applet
Summary: Ridiciously long message in rhn-applet
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-30 16:35 UTC by Christian Rose
Modified: 2007-04-18 16:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-04 21:40:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2002-08-30 16:35:04 UTC
#: ../rhn_applet_dialogs.py:270
msgid ""
"\n"
"Red Hat Network provides an intelligent, proactive management service\n"
"for your Red Hat Linux-based system.  Red Hat Network has the latest\n"
"Red Hat information, updates, and services to make your systems more\n"
"secure and reliable.  This application is designed to inform you when\n"
"updates are available for your system, but does not save any\n"
"personally identifiable information about you or your system to the\n"
"Red Hat Network unless you choose to subscribe to Red Hat Network.\n"
"Use of this applet by itself does not imply any agreement with Red Hat\n"
"Network.\n"
"<br><br>\n"
"Use of the up2date service, or use of this applet in conjunction with the\n"
"up2date service, is governed by the Red Hat Network Services Use and\n"
"Subscription Agreement, which may be reviewed at\n"
"<a href=\"https://rhn.redhat.com/help/terms.pxt\">https://rhn.redhat.com/"
"help/terms.pxt</a>.\n"
"<br><br>\n"
"Red Hat Network's privacy policy may be reviewed at \n"
"<a href=\"https://rhn.redhat.com/help/security.pxt\">https://rhn.redhat.com/"
"help/security.pxt</a>.\n"
"<br><br>\n"
"If you do not wish to have this application appear on your panel,\n"
"click the 'Remove From Panel' button below.  Once removed, you can return it "
"to your panel at any time by\n"
"choosing 'Red Hat Network Alert Notification Tool' from 'Add to Panel|Applet|"
"Monitors' in the Panel menu.\n"
"        "
msgstr ""

This message is ridociouosly long and close to impossible to translate, and even
more impossible to maintain the translation of, since tiny changes will be
impossible to spot in this giant message.

A good rule of thumb is to use one message for each paragraph -- what is an
appropriate length to group text in and easy to read is also an appropriate
length of a message for translation. Please consider splitting this message into
smaller paragraph-sized messages.

Also, please consider the use of automatic line-wrapping instead of all those
fixed line breaks (helps both accessibility and translation).

Comment 1 Chip Turner 2002-10-03 16:22:57 UTC
fixed in CVS, will be on i18n.redhat.com soon

Comment 2 Göran Uddeborg 2003-10-04 21:06:07 UTC
Looks fixed now.  I suggest closing this.

Comment 3 Daniel Veillard 2003-10-04 21:40:24 UTC
Right ! Strings have been cut at least to small paragraph levels. I hope
it eased the work for translators,

  thanks,

Daniel


Note You need to log in before you can comment on or make changes to this bug.