Bug 730886 - [xfs/xfstests 253] xfs_db metadump hang forever
Summary: [xfs/xfstests 253] xfs_db metadump hang forever
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfsprogs
Version: 6.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Branislav Náter
URL:
Whiteboard:
Depends On: 714934
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 06:23 UTC by Eryu Guan
Modified: 2012-06-20 14:11 UTC (History)
2 users (show)

Fixed In Version: xfsprogs-3.1.1-7.el6
Doc Type: Bug Fix
Doc Text:
No Documentation needed (not customer reported)
Clone Of: 714934
Environment:
Last Closed: 2012-06-20 14:11:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0883 normal SHIPPED_LIVE xfsprogs bug fix update 2012-06-19 19:50:53 UTC

Description Eryu Guan 2011-08-16 06:23:02 UTC
Seems xfsprogs-3.1.1-6.el6 also has this problem. Clone for rhel6

+++ This bug was initially created as a clone of Bug #714934 +++

Description of problem:
xfstests 253 will never complete, from the test description:
This test was created to verify fixes for problems where metadump
would never complete due to an inability to find a suitable
obfuscated name to use.

Version-Release number of selected component (if applicable):
# rpm -qa | grep xfsprogs
xfsprogs-2.10.2-7.el5
xfsprogs-devel-2.10.2-7.el5

kernel-2.6.18-268.el5

How reproducible:
100%

Steps to Reproduce:
1. Install xfstests
2. check 253
3.
  
Actual results:
Test will never complete

Expected results:
Test pass

Additional info:
I think this should be the xfsprogs component, if a kernel fix is needed, please correct me.

--- Additional comment from esandeen@redhat.com on 2011-06-21 11:07:05 EDT ---

xfsprogs is the correct component, there are upstream metadump fixes which we don't have in rhel5 and this test exercises them explicitly.

Comment 2 RHEL Product and Program Management 2011-10-07 16:12:50 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Eric Sandeen 2011-10-12 17:31:22 UTC
This is an expected failure which is fixed upstream, we will need the series starting at

56281ed43abe95e96e45d2287fd0b965b7d4d2b8 xfsprogs: metadump: some names aren't all that special

as a backport, to fix it.

Comment 10 Eric Sandeen 2012-04-25 21:08:57 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed (not customer reported)

Comment 12 errata-xmlrpc 2012-06-20 14:11:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0883.html


Note You need to log in before you can comment on or make changes to this bug.