Bug 730912 - VDSM: Cannot remove all templates with 'Logical volume does not exist' error
Summary: VDSM: Cannot remove all templates with 'Logical volume does not exist' error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Eduardo Warszawski
QA Contact: Dafna Ron
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 08:29 UTC by Dafna Ron
Modified: 2011-12-06 07:37 UTC (History)
5 users (show)

Fixed In Version: vdsm-4.9-93
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:37:05 UTC


Attachments (Terms of Use)
log (1.22 MB, application/octet-stream)
2011-08-16 08:29 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Dafna Ron 2011-08-16 08:29:06 UTC
Created attachment 518420 [details]
log

Description of problem:

trying to remove templates (even just newly created templates) get a 'Logical volume does not exist' error from vdsm. 

this only opens with templates - not all images. 

Version-Release number of selected component (if applicable):

vdsm-4.9-92.el6.x86_64

How reproducible:

100% 

Steps to Reproduce:
1. create or import template
2. try to delete it 
3.
  
Actual results:

template cannot be deleted. 

Expected results:


Additional info: log attached. 


Thread-67947::WARNING::2011-08-16 11:19:24,151::lvm::484::Storage.LVM::(_reloadlvs) lvm lvs failed: 5 [] ['  Volume group "a8ba862d-984e-4004-829a-5a482f2e1c69" not found', '  S
kipping volume group a8ba862d-984e-4004-829a-5a482f2e1c69']
Thread-67947::DEBUG::2011-08-16 11:19:24,152::lvm::509::OperationMutex::(_reloadlvs) Operation 'lvm reload operation' released the operation mutex
Thread-67947::ERROR::2011-08-16 11:19:24,153::task::865::TaskManager.Task::(_setError) Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/spm.py", line 115, in run
    return self.func(*args, **kwargs)
  File "/usr/share/vdsm/storage/spm.py", line 1515, in public_deleteImage
    image.Image(repoPath).validateDelete(sdUUID, imgUUID)
  File "/usr/share/vdsm/storage/image.py", line 173, in validateDelete
    images = vol.findImagesByVolume(legal=True)
  File "/usr/share/vdsm/storage/blockVolume.py", line 431, in findImagesByVolume
    volumes.append(lvm.getLV(self.volUUID))
  File "/usr/share/vdsm/storage/lvm.py", line 824, in getLV
    raise se.LogicalVolumeDoesNotExistError("%s/%s" % (vgName, lvName))
LogicalVolumeDoesNotExistError: Logical volume does not exist: ('a8ba862d-984e-4004-829a-5a482f2e1c69/None',)
Thread-67947::DEBUG::2011-08-16 11:19:24,154::task::492::TaskManager.Task::(_debug) Task da872c6b-8aeb-49f8-b0a5-53bca2dcc021: Task._run: da872c6b-8aeb-49f8-b0a5-53bca2dcc021 ('
c8ee07dc-55ab-4c9c-8028-a1a5b0eb9379', '22e84013-86d4-4086-b0f5-50ee40545659', '0bbcbe75-3b73-4e72-bba5-efb030764be9', 'false', 'false') {} failed - stopping task
Thread-67947::DEBUG::2011-08-16 11:19:24,155::task::492::TaskManager.Task::(_debug) Task da872c6b-8aeb-49f8-b0a5-53bca2dcc021: stopping in state preparing (force False)
Thread-67947::DEBUG::2011-08-16 11:19:24,155::task::492::TaskManager.Task::(_debug) Task da872c6b-8aeb-49f8-b0a5-53bca2dcc021: ref 1 aborting True
Thread-67947::INFO::2011-08-16 11:19:24,156::task::1177::TaskManager.Task::(prepare) aborting: Task is aborted: 'Logical volume does not exist' - code 610

Comment 1 yeylon@redhat.com 2011-08-16 10:23:36 UTC
note that this is a regression from vdsm91!

why VDSM unit tests are not being executed every build???

Comment 4 Eduardo Warszawski 2011-08-16 13:22:22 UTC
http://gerrit.usersys.redhat.com/#change,817

Comment 6 Tomas Dosek 2011-08-25 09:18:12 UTC
Verified - vdsm-4.9-95 - Above specified scenario no longer reproduces, templates are deleted without producing any Unexpected exception.

Comment 7 errata-xmlrpc 2011-12-06 07:37:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.