Bug 730918 - v7 server daemon fails on startup - can not create task file
Summary: v7 server daemon fails on startup - can not create task file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 08:51 UTC by Caspar Zhang
Modified: 2015-02-08 21:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-08 15:42:40 UTC


Attachments (Terms of Use)
daemon patch to make task file directory if it does not exist (425 bytes, patch)
2011-08-16 18:46 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1436 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-11-08 23:28:41 UTC

Description Caspar Zhang 2011-08-16 08:51:46 UTC
Description of problem:

running v7 server start, the server started successfully, but the following message printed:

[root@dell-per210-01 ~]# v7 server start
Checking installed rpms:
package fence-agents is not installed
The following rpms are required for testing:
 fence-agents
Would you like to install them now? (y|n) n
response: n
Warning: some tests may fail due to missing rpms
kdump test server start:
Starting NFS services:  [  OK  ]
Starting NFS quotas: [  OK  ]
Starting NFS daemon: [  OK  ]
Starting NFS mountd: [  OK  ]

network test server start:
Starting lmbench services... done.
Starting httpd: [  OK  ]

Starting v7 daemon
[root@dell-per210-01 ~]# Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in <module>
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 184, in do
    return self.doServer(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 450, in doServer
    return daemon.run() 
  File "/usr/share/v7/lib/v7/daemon.py", line 61, in run
    self.__clearPipes()
  File "/usr/share/v7/lib/v7/daemon.py", line 52, in __clearPipes
    os.mkfifo(self.environment.getTaskFilePath()+ ".in", 0666)
OSError: [Errno 2] No such file or directory


Version-Release number of selected component (if applicable):
1.4 R16


How reproducible:
always

Steps to Reproduce:
1. v7 server start
2.
3.
  
Actual results:


Expected results:
no extra python backtrace

Additional info:

Comment 1 Greg Nichols 2011-08-16 18:30:54 UTC
The traceback happens when the v7 server is started on a system that has never run v7 plan/certify/run.    The work-around is to run "v7 plan" before running "v7 server start"

Comment 2 Greg Nichols 2011-08-16 18:46:16 UTC
Created attachment 518554 [details]
daemon patch to make task file directory if it does not exist

Comment 3 Greg Nichols 2011-08-18 19:12:51 UTC
Committed to R17

Comment 6 Caspar Zhang 2011-10-21 14:03:11 UTC
This bug doesn't need a TechNote because of:

a) it was discovered in a v7 1.4 intermediate version, and
b) it was discovered by a Red Hat associate only.

Comment 7 errata-xmlrpc 2011-11-08 15:42:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Comment 8 errata-xmlrpc 2011-11-08 18:31:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html


Note You need to log in before you can comment on or make changes to this bug.