This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 730923 - virt-install: support <graphics> connected='keep|disconnect|fail'
virt-install: support <graphics> connected='keep|disconnect|fail'
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 05:08 EDT by zhpeng
Modified: 2014-07-06 15:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 09:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description zhpeng 2011-08-16 05:08:13 EDT
Description of problem:
when using virt-manager to set vnc/spice password, it does not support option "connected='keep|disconnect|fail'".

Version-Release number of selected component (if applicable):
kernel-2.6.32-189.el6.x86_64
libvirt-0.9.4-4.el6.x86_64
qemu-kvm-0.12.1.2-2.183.el6.x86_64
virt-manager-0.9.0-5.el6.x86_64

How reproducible:
every time

Steps to Reproduce:
1.open one virtual machine hardware detail tab(guest os is shutdown)
2.select "Display VNC"/"Display Spice" or "Add Hardware"-"Graphic"
3.set password, there is no option set "connected='keep|disconnect|fail'"


Actual results:
can not set option "connected='keep|disconnect|fail'"


Expected results:
1.virt-manager support select VNC/Spice  "connected='keep|disconnect|fail'" option when add password.
Comment 2 Cole Robinson 2011-08-29 10:47:48 EDT
Since this is an RFE and not high priority, deferring to 6.3
Comment 4 Cole Robinson 2011-12-09 18:05:56 EST
Not urgent, and given reduced capacity for virt-manager/virtinst, just moving
this to the upstream tracker.
Comment 5 Cole Robinson 2012-02-07 11:13:00 EST
I don't think end users are going to want to set this option very often, so I don't think it makes sense to add to virt-manager UI. Doing so at virt-install level is okay, so reassigning there.
Comment 6 Cole Robinson 2013-04-21 15:12:15 EDT
virtinst has been merged into virt-manager.git. Moving all virtinst bugs to the virt-manager component.
Comment 8 Cole Robinson 2014-01-29 09:54:10 EST
Fixed upstream now

Note You need to log in before you can comment on or make changes to this bug.