Bug 730946 - Cannot discover iSCSI HBA luns in RHEVMstorage tab
Summary: Cannot discover iSCSI HBA luns in RHEVMstorage tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Saggi Mizrahi
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 10:38 UTC by Guohua Ouyang
Modified: 2011-12-06 07:37 UTC (History)
13 users (show)

Fixed In Version: vdsm-4.9-96.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:37:08 UTC


Attachments (Terms of Use)
vdsm.log (23.79 KB, text/plain)
2011-08-16 10:38 UTC, Guohua Ouyang
no flags Details
rhevm.log (5.20 KB, text/plain)
2011-08-16 10:41 UTC, Guohua Ouyang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Guohua Ouyang 2011-08-16 10:38:09 UTC
Description of problem:
rhevh installed on iSCSI HBA storage which have more than one luns, on RHEVM storage tab, cannot discover the iSCSI luns.


[root@amd-1352-8-5 data]# multipath -ll
1ATA_WDC_WD2502ABYS-18B7A0_WD-WCAT19558392 dm-1 ATA,WDC WD2502ABYS-1
size=233G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  `- 0:0:0:0 sda 8:0  active ready running
36090a038d0f7b10e4de4d456d0003037 dm-0 EQLOGIC,100E-00
size=20G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  `- 5:0:0:0 sdb 8:16 active ready running
36090a038d0f7f1b285c904beee635293 dm-2 EQLOGIC,100E-00
size=25G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  `- 5:0:1:0 sdc 8:32 active ready running

[root@amd-1352-8-5 data]# vdsClient -s 0 getDeviceList
[{'GUID': '36090a038d0f7f1b285c904beee635293',
  'capacity': '26848788480',
  'devtype': 'FCP',
  'fwrev': '5.0',
  'partitioned': False,
  'pathlist': [],
  'pathstatus': [{'lun': '0',
                  'physdev': 'sdc',
                  'state': 'active',
                  'type': 'FCP'}],
  'productID': '100E-00',
  'pvUUID': '',
  'serial': 'SEQLOGIC_100E-00_6090A038D0F7F1B285C904BEEE635293',
  'vendorID': 'EQLOGIC',
  'vgUUID': ''}]


Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.12.hybrid1313452873
vdsm-4.9-92.el6.auto1313452873.x86_64

How reproducible:
Always.

Steps to reproduce:
1. Install rhevh on iSCSI storage which have two luns connected by iSCSI HBA.
2. Register to RHEVM.
3. Approve it to iSCSI type storage.
4. switch to storage tab in RHEVM, select iSCSI datacenter, it will try to discover iSCSI luns.

Actual results:
Cannot discover any luns.

Expected results:
The iSCSI lun which without rhevh installed should be listed there.

Additional info:
Discover a soft iSCSI targets and login and add the storage successfully. this bug is report against the iSCSI lun connected by HBA.

Mark this bug as regression because 692874 has been fixed in rhev-hypervisor-6.1-20110427.0.el6 + vdsm-4.9-62.el6.x86_64 + IC114.

Comment 1 Guohua Ouyang 2011-08-16 10:38:41 UTC
Created attachment 518456 [details]
vdsm.log

Comment 5 Ayal Baron 2011-08-16 11:29:28 UTC
I don't understand what the problem is.  
These devices are partitioned:
36090a038d0f7b10e4de4d456d0003037
1ATA_WDC_WD2502ABYS-18B7A0_WD-WCAT19558392

And this device does return back to rhevm: 36090a038d0f7f1b285c904beee635293


From the log:

Thread-189::WARNING::2011-08-16 17:07:48,569 ... Ignoring partitioned device ... 'guid': '36090a038d0f7b10e4de4d456d0003037'

Thread-189::WARNING::2011-08-16 17:07:48,577 ... Ignoring partitioned device ... 'guid': '1ATA_WDC_WD2502ABYS-18B7A0_WD-WCAT19558392'

Thread-189::DEBUG::2011-08-16 17:07:48,587 ... Task 86eaa2b3-29e6-441a-b1e8-170e5822d607: finished: {'devList': [{'fwrev': '5.0', 'vgUUID': '', 'pathlist': [], 'devtype': 'FCP', 'serial': 'SEQLOGIC_100E-00_6090A038D0F7F1B285C904BEEE635293', 'GUID': '36090a038d0f7f1b285c904beee635293', 'productID': '100E-00', 'vendorID': 'EQLOGIC', 'capacity': '26848788480', 'partitioned': False, 'pathstatus': [{'physdev': 'sdc', 'state': 'active', 'type': 'FCP', 'lun': '0'}], 'pvUUID': ''}]}

Comment 6 Dan Kenigsberg 2011-08-17 19:39:18 UTC
http://gerrit.usersys.redhat.com/823

Comment 8 Daniel Paikov 2011-08-28 11:48:41 UTC
We don't have iSCSI HBA devices to test this on. Re-assigning the bug back to gouyang.

Comment 9 Guohua Ouyang 2011-09-05 06:13:56 UTC
Verified on rhevh 6.2-0.15, vdsm version 4.9-96:
on storage page, it discovered the iSCSI HBA lun and added the storage domain successfully.

Comment 10 errata-xmlrpc 2011-12-06 07:37:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.