Bug 730960 - "Bootloader" option in kickstart doesn't work
"Bootloader" option in kickstart doesn't work
Status: CLOSED DUPLICATE of bug 727679
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-16 07:46 EDT by Kamil Páral
Modified: 2011-08-16 10:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 10:23:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration (38.93 KB, image/png)
2011-08-16 07:46 EDT, Kamil Páral
no flags Details
kickstart used (1.05 KB, text/plain)
2011-08-16 07:46 EDT, Kamil Páral
no flags Details
Kickstart with bootloader that worked (1.39 KB, application/octet-stream)
2011-08-16 08:31 EDT, Robert Lightfoot
no flags Details
anaconda.log (15.25 KB, text/plain)
2011-08-16 08:56 EDT, Kamil Páral
no flags Details
program.log (21.82 KB, text/plain)
2011-08-16 08:56 EDT, Kamil Páral
no flags Details
syslog (65.59 KB, text/plain)
2011-08-16 08:56 EDT, Kamil Páral
no flags Details
storage.log (78.22 KB, text/plain)
2011-08-16 08:57 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-08-16 07:46:33 EDT
Created attachment 518470 [details]
bug demonstration

Description of problem:
I've tried to install F16 Alpha RC4 using kickstart. I have tried these commands in my kickstart file:

bootloader

or

bootloader --location=mbr

Both options causes anaconda to say "There was an error installing the bootloader." See screenshot.

I believe this is caused by the transitions to GPT.

But the documentation doesn't state any other way how to specify the bootloeader location:
http://fedoraproject.org/wiki/Anaconda/Kickstart#bootloader

The system fails to boot after installation.

Version-Release number of selected component (if applicable):
anaconda-16.14.5

How reproducible:
always
 
Actual results:
installation is not possible

Expected results:
1. "bootloader" option has reasonable default location that works
2. other locations are documented

Additional info:
My kickstart appended.
Comment 1 Kamil Páral 2011-08-16 07:46:59 EDT
Created attachment 518471 [details]
kickstart used
Comment 2 Kamil Páral 2011-08-16 07:47:37 EDT
Setting as F16 Beta blocker:

The installer must be able to use all kickstart delivery methods
https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 3 David Lehman 2011-08-16 07:57:46 EDT
Any time you report a bug against anaconda it is helpful to include the following logs from the shell on tty2:

 /tmp/anaconda.log
 /tmp/storage.log
 /tmp/program.log
 /tmp/syslog

It is strongly preferred that you attach each file separately as plain text.
Comment 4 Robert Lightfoot 2011-08-16 08:31:41 EDT
Created attachment 518476 [details]
Kickstart with bootloader that worked

I did this same test without this bug.  My ks is different and provided for reference.
Comment 5 Kamil Páral 2011-08-16 08:56:28 EDT
Created attachment 518478 [details]
anaconda.log
Comment 6 Kamil Páral 2011-08-16 08:56:43 EDT
Created attachment 518479 [details]
program.log
Comment 7 Kamil Páral 2011-08-16 08:56:59 EDT
Created attachment 518480 [details]
syslog
Comment 8 Kamil Páral 2011-08-16 08:57:30 EDT
Created attachment 518481 [details]
storage.log

14:49:08,526 ERR program: Generating grub.cfg ...
14:49:09,368 ERR program: Found linux image: /boot/vmlinuz-3.0.0-1.fc16.x86_64
14:49:09,561 ERR program: Found initrd image: /boot/initramfs-3.0.0-1.fc16.x86_64.img
14:49:13,851 ERR program:   No volume groups found
14:49:14,272 ERR program: done
14:49:14,480 INFO program: Running... grub2-install (hd0)
14:49:24,774 ERR program: /usr/sbin/grub2-setup: warn: This GPT partition label has no BIOS Boot Partition; embedding won't be possible!.
14:49:24,782 ERR program: /usr/sbin/grub2-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
14:49:24,783 ERR program: /usr/sbin/grub2-setup: error: will not proceed with blocklists.
Comment 9 Chris Lumens 2011-08-16 10:23:52 EDT

*** This bug has been marked as a duplicate of bug 727679 ***

Note You need to log in before you can comment on or make changes to this bug.