Bug 730962 - When using pam authentication in squid, AVC denial about netlink_audit_socket
When using pam authentication in squid, AVC denial about netlink_audit_socket
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 07:57 EDT by Jan Pazdziora
Modified: 2013-06-03 08:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-317.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2011-08-16 07:57:17 EDT
Description of problem:

When we use squid with pam authentication, we get the following AVC denials:

type=AVC msg=audit(1313494716.857:195): avc:  denied  { create } for  pid=1413 comm="pam_auth" scontext=root:system_r:squid_t:s0 tcontext=root:system_r:squid_t:s0 tclass=netlink_audit_socket
type=AVC msg=audit(1313494716.858:196): avc:  denied  { write } for  pid=1413 comm="pam_auth" scontext=root:system_r:squid_t:s0 tcontext=root:system_r:squid_t:s0 tclass=netlink_audit_socket
type=AVC msg=audit(1313494716.858:196): avc:  denied  { nlmsg_relay } for  pid=1413 comm="pam_auth" scontext=root:system_r:squid_t:s0 tcontext=root:system_r:squid_t:s0 tclass=netlink_audit_socket
type=AVC msg=audit(1313494716.858:196): avc:  denied  { audit_write } for  pid=1413 comm="pam_auth" capability=29 scontext=root:system_r:squid_t:s0 tcontext=root:system_r:squid_t:s0 tclass=capability
type=AVC msg=audit(1313494716.858:198): avc:  denied  { read } for  pid=1413 comm="pam_auth" scontext=root:system_r:squid_t:s0 tcontext=root:system_r:squid_t:s0 tclass=netlink_audit_socket

This was gathered in permissive.

Version-Release number of selected component (if applicable):

# rpm -q redhat-release selinux-policy squid
redhat-release-5Server-5.7.0.3
selinux-policy-2.4.6-316.el5
squid-2.6.STABLE21-6.el5

How reproducible:

Deterministic.

Steps to Reproduce:
1. Comment out http_access in /etc/squid/squid.conf and add lines like

auth_param basic program /usr/lib64/squid/pam_auth 
                      acl pam proxy_auth REQUIRED
                      acl all src 0.0.0.0/0.0.0.0
                      http_access allow pam
                      http_access allow localhost
                      http_access deny all

to it, then try to use the squid.
  
Actual results:

AVC denials line above, in the case of enforcing the operation fails.

Expected results:

No AVC denials.

Additional info:
Comment 3 Miroslav Grepl 2011-08-22 09:04:31 EDT
We have in RHEL6

auth_domtrans_chk_passwd(squid_t)

which allow this.
Comment 5 Miroslav Grepl 2011-09-29 07:26:43 EDT
Fixed in selinux-policy-2.4.6-317.el5
Comment 8 errata-xmlrpc 2012-02-21 00:47:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html

Note You need to log in before you can comment on or make changes to this bug.