Bug 730967 - service jabberd restart fails on stopping s2s
Summary: service jabberd restart fails on stopping s2s
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jabberd
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 12:19 UTC by Jiří Mikulka
Modified: 2014-10-06 13:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-01 22:25:17 UTC


Attachments (Terms of Use)

Description Jiří Mikulka 2011-08-16 12:19:09 UTC
Description of problem:
Although `service jabberd status` says that all components of jabberd service are running (router, sm, c2s, s2s), in few cases `service jabberd restart` fails when stopping s2s service, but s2s service is then started well.

Version-Release number of selected component (if applicable):
jabberd-2.2.14-1.fc14.src.rpm (but also sometimes on f15 and rhel5, rhel6)

How reproducible:
I cannot reproduce this bug deterministically, but it happens.
  
Actual results:
Router, sm, c2s are stopped and then run ok, but sometimes s2s fails to stop, but everytime it is run without troubles.

Expected results:
Router, sm, c2s, s2s are stopped and then run without any troubles.

Comment 1 Dominic Hopf 2011-12-18 17:50:15 UTC
Can you check if the s2s process is present before restarting to see if this happens when the process isn't present anymore? If this is the case, could you provide me with the messages the s2s process has logged into /var/log/messages before?

Comment 2 Mark Huth 2012-02-29 20:20:10 UTC
Sounds the same as this: https://bugzilla.redhat.com/show_bug.cgi?id=745684

Comment 3 Jiří Mikulka 2012-03-15 14:30:44 UTC
Dominic, (sorry for my very late response) currently I'm not able to reproduce this bug, but as I can remember, it had sth in common with ipv6 configuration in /etc/jabberd/*.xml. I tested this today with the jabberd-2.2.14-1.el6 package and I wasn't able to reproduce it, but when I got machine with fresh Spacewalk installation, the bug was reproducible just for one try.

Comment 4 Jiří Mikulka 2012-06-21 10:45:13 UTC
Hi Dominic, as Mark wrote in comment 2, the whole issue is precisely described in bug 745684 together with the solution, which should work also in my case.

Comment 5 Adrian Reber 2012-06-21 11:30:35 UTC
I get

You are not authorized to access bug #745684. 

Can this be changed, so that we can have a look at that bugreport.

Comment 6 Jan Pazdziora 2012-06-26 09:53:29 UTC
I flipped bug 745684 public.

Basically, the idea is to process the services in reverse order upon stop:

< for prog in ${progs}; do
> for prog in $(echo ${progs} | tac -s ' '); do

I did not check if it's directly applicable to the init script which is in Fedora thou.

Comment 7 Fedora Update System 2012-07-24 08:39:52 UTC
jabberd-2.2.14-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/jabberd-2.2.14-3.fc17

Comment 8 Fedora Update System 2012-07-24 08:49:49 UTC
jabberd-2.2.14-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/jabberd-2.2.14-3.el6

Comment 9 Fedora Update System 2012-07-24 23:30:58 UTC
Package jabberd-2.2.14-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jabberd-2.2.14-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11058/jabberd-2.2.14-3.fc17
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2012-08-01 22:25:17 UTC
jabberd-2.2.14-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2012-08-10 18:40:19 UTC
jabberd-2.2.14-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.