Bug 730975 - Openswan doesn't work with ike=modp1536 option
Openswan doesn't work with ike=modp1536 option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openswan (Show other bugs)
6.1
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Paul Wouters
Jaroslav Aster
:
Depends On:
Blocks: 1105171
  Show dependency treegraph
 
Reported: 2011-08-16 08:54 EDT by David Spurek
Modified: 2015-03-02 00:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1105171 (view as bug list)
Environment:
Last Closed: 2014-10-14 04:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1588 normal SHIPPED_LIVE openswan bug fix and enhancement update 2014-10-13 21:39:53 EDT

  None (edit)
Description David Spurek 2011-08-16 08:54:03 EDT
Description of problem:
Openswan doesn't work with ike=modp1536 option, which is suggested as one of examples in manual pages of ipsec.conf.

Version-Release number of selected component (if applicable):
openswan-2.6.32-4.el6_1.1

How reproducible:
always

Steps to Reproduce:
1.cp ipsec.conf /etc/ipsec.conf

version    2.0

config setup
    protostack=netkey
    nat_traversal=yes
    plutostderrlog=/var/log/pluto.log

conn testA
        auto=add
        authby=secret
        type=transport
        left=127.0.0.1
        right=127.0.0.1
        ike=modp1536
        phase2=esp
        phase2alg=aes-sha1
        loopback=yes


2.cp ipsec.secrets /etc/ipsec.secrets

: PSK "whatever"


3.ip xfrm state flush
4.service ipsec restart
5.ipsec auto --up testA
6.ip xfrm state
  
Actual results of ipsec auto --up testA:

000 initiating all conns with alias='testA' 
021 no connection named "testA"

Expected results:
Succesfully create an IPsec connection

Additional info:
I have checked output of tcpdump, packets are unencrypted.
Comment 2 RHEL Product and Program Management 2011-08-16 09:08:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 RHEL Product and Program Management 2012-05-03 01:11:22 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-09-28 10:11:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Paul Wouters 2013-05-17 15:10:05 EDT
parser should get fixed.

workaround: specify the algo/hash as well: ike=aes-sha1;modp1536
Comment 8 Jaroslav Aster 2014-06-05 07:48:32 EDT
Hi,

I can confirm it and then I did some tests and found out that there is something wrong in parsing ike option. A lot of more things do not work and end with same error.

example:


1, all alone dh

ike=modp1536 # fail
ike=dh22 # fail
ike=dh23 # fail
ike=dh24 # fail
...

2, all alone hash

ike=md5 # fail
ike=sha1 # fail

3, mix dh and hash

ike=md5;dh22 # fail
ike=sha1;modp1024 # fail
...

4, 

ike=aes-md5;dh22,modp1024 # fail

Man pages says that it should be possible to set these values, ike=modp1536 is as an example in man page ipsec.conf.

It seems only values from right can miss.

ike=aes-md5;dh22,3des # pass
ike=aes-md5,3des # pass
ike=aes,3des # pass
Comment 9 Jaroslav Aster 2014-06-05 07:50:08 EDT
I tested it on rhel6.5.z and openswan-2.6.32-27.el6.
Comment 13 errata-xmlrpc 2014-10-14 04:18:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1588.html

Note You need to log in before you can comment on or make changes to this bug.