Bug 731105 - Can't create a local repository
Summary: Can't create a local repository
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Shannon Hughes
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-16 17:24 UTC by Mike McCune
Modified: 2013-03-27 20:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:52:41 UTC


Attachments (Terms of Use)

Description Mike McCune 2011-08-16 17:24:01 UTC
The URL input form for creating a repo does not allow for local directories so you can sync from an NFS mount or a mounted ISO.  Trying to specify:

/opt/repo
file:////opt/repo/

results in "Invalid URL" errors.

Comment 1 Mike McCune 2011-08-16 17:25:46 UTC
The problem is in the regex in:

module KatelloUrlHelper

Needs to support file based URLs.

Comment 2 Shannon Hughes 2011-08-22 19:01:54 UTC
added in regex to handle file based urls

Comment 3 Sachin Ghai 2011-08-25 11:50:35 UTC
Verified with following katello build:

[root@dhcp201-167 repo]# rpm -qa | grep katello
katello-cli-0.1.5-1.git.15.654a7df.fc15.noarch
katello-0.1.70-1.git.7.ca8d03c.fc15.noarch
[root@dhcp201-167 repo]# 


Now we can create file based local repos. I used following url for file based local repo's 

file:///opt/repo

Here is the output from pulp-admin, after creating a repo from webUI

Id                 	1314271265142-test_file_based_repo-ACME_Corporation
Name               	test_file_based_repo     
Feed URL           	file:///opt/repo         
Feed Type          	local                    
Content Type       	yum                      
Feed Certs         	CA:No   Cert:No
Consumer Certs     	CA:No   Cert:No
Architecture       	noarch                   
Sync Schedule      	None                     
Packages           	32                       
Files              	0                        
Distributions      	None                     
Publish            	True                     
Clones             	[]                       
Groups             	[u'product:1314271265142', u'env:1', u'org:1']
Filters            	[]                       
Notes              	None


Note You need to log in before you can comment on or make changes to this bug.