Bug 73111 - border characters corrupted in tui upgrade from 7.2 w/ full lang support
border characters corrupted in tui upgrade from 7.2 w/ full lang support
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-30 17:06 EDT by Mike McLean
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 17:36:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg used for the initial 7.2 install that I upgraded from (994 bytes, text/plain)
2002-08-30 18:22 EDT, Mike McLean
no flags Details
anaconda-ks.cfg left by the upgrade (738 bytes, text/plain)
2002-08-30 18:28 EDT, Mike McLean
no flags Details
upgrade.log from the (manual) upgrade (43.01 KB, text/plain)
2002-08-30 18:29 EDT, Mike McLean
no flags Details

  None (edit)
Description Mike McLean 2002-08-30 17:06:34 EDT
* Milan-re0830.0
* English kickstart FTP upgrade from 7.2/everything

The TUI border characters used for the outlines of the windows are being printed
as accented A's and U's and as superscripted 3's.  This is similar to what was
happening in bug#33208 and bug#67622.

What is odd is the specific situation required to produce the bug.  An upgrade
from 7.2/minimal does not produce it.  I think it probably has something to do
with the supported languages of the 7.2 installation.

I'll try some other test cases and see if I can get the bug in a non-kickstart
install.
Comment 1 Mike McLean 2002-08-30 17:38:16 EDT
kickstart upgrade from 7.2/minimal/all_languages_supported produces the same problem
Comment 2 Mike McLean 2002-08-30 18:16:15 EDT
Verified with manual upgrade.  The installation starts out normal, but at some
point (sorry I missed exactly where) during the package installation, the
characters switch.  Will attach the ks.cfg I used to make the initial 7.2 install.
Comment 3 Mike McLean 2002-08-30 18:22:11 EDT
Created attachment 74064 [details]
ks.cfg used for the initial 7.2 install that I upgraded from
Comment 4 Mike McLean 2002-08-30 18:28:04 EDT
Created attachment 74084 [details]
anaconda-ks.cfg left by the upgrade
Comment 5 Mike McLean 2002-08-30 18:29:31 EDT
Created attachment 74085 [details]
upgrade.log from the (manual) upgrade
Comment 6 Jeremy Katz 2003-01-03 00:34:08 EST
I'm guessing this is because a scriptlet was getting unicode_start to run which
would have really confused the newt we had for the installer in 8.0.  Does this
seem to do better with the current tree?
Comment 7 Mike McLean 2003-01-20 17:36:24 EST
I haven't seen this in a long time.  Closing.

Note You need to log in before you can comment on or make changes to this bug.