Bug 731115 - serial file path is converted to lower case?
Summary: serial file path is converted to lower case?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 18:30 UTC by Gurhan Ozen
Modified: 2011-08-30 13:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 15:26:17 UTC


Attachments (Terms of Use)

Description Gurhan Ozen 2011-08-16 18:30:43 UTC
Description of problem:
Not sure if this is a virt-install issue or a libvirt issue:
# ls -ltrd /mnt/tests/distribution/virt/install/RH6_x86_64_hvm_guest
drwxrwxrwx. 4 root root 4096 Aug 16 12:54 /mnt/tests/distribution/virt/install/RH6_x86_64_hvm_guest

# virt-install --name RH6_x86_64_hvm_guest --location nfs://bigpapi.bos.redhat.com:/vol/engarchive2/redhat/released/RHEL-6/6.0/Client/x86_64/os --nonsparse --hvm -s 9 -f /var/lib/libvirt/images/RH6_x86_64_hvm_guest_aaaa.img --debug --extra-args ks=http://lab2.rhts.eng.bos.redhat.com/cblr/svc/op/ks/system/guest-80-99.rhts.eng.bos.redhat.com --prompt  --accelerate --os-variant=virtio26  --network bridge:br0  --serial file,path=/mnt/tests/distribution/virt/install/RH6_x86_64_hvm_guest/logs/console.log

This fails because the console log file has upper case letters: "/mnt/tests/distribution/virt/install/RH6_x86_64_hvm_guest/logs/console.log" , yet libvirtd is trying to write it to all lower-case file name:


    <serial type='file'>
      <source path='/mnt/tests/distribution/virt/install/rh6_x86_64_hvm_guest/logs/console.log'/>
    </serial>

What's worse is , trying to write to a non-existent serial log file crashes libvirtd but there will be another BZ for that. This was for rhel6.0 not tested it on 6.1 or 6.2 yet.

Version-Release number of selected component (if applicable):
python-virtinst-0.500.3-7.el6.noarch
libvirt-0.8.1-27.el6.x86_64


How reproducible:
Very

Steps to Reproduce:
1. Do a vm install with virt-install and pass on --serial file,path=/PATH/TO/FILE where path includes uppercase letters.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Dave Allan 2011-08-16 19:02:06 UTC
Gurhan, can you repro with 6.2 and virsh define?

Comment 3 Gurhan Ozen 2011-08-17 05:24:10 UTC
(In reply to comment #2)
> Gurhan, can you repro with 6.2 and virsh define?

I tried to same with 6.2 (RHEL6.2-20110816.n.1 distro) and that works just fine:

    <serial type='file'>
      <source path='/mnt/tests/distribution/virt/install/GuestTwo_ser/no.log'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='file'>
      <source path='/mnt/tests/distribution/virt/install/GuestTwo_ser/no.log'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
    </console>


Note You need to log in before you can comment on or make changes to this bug.