Bug 731188 - [abrt] kernel: [ INFO: possible recursive locking detected ]
[abrt] kernel: [ INFO: possible recursive locking detected ]
Status: CLOSED DUPLICATE of bug 722472
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:2e53507603d44898088eda01337...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 17:15 EDT by Rudolf Kastl
Modified: 2011-08-16 19:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 19:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2011-08-16 17:15:50 EDT
abrt version: 2.0.5
cmdline:        initrd=initrd0.img root=live:UUID=a6418d53-10fe-4d0e-8f78-3f676e886c09 rootfstype=ext4 ro liveimg  LANG=de_DE.utf8 quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0   BOOT_IMAGE=vmlinuz0 
comment:        booted from f16 alpha rc4
kernel:         undefined
reason:         [ INFO: possible recursive locking detected ]
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           Tue Aug 16 16:40:24 2011

backtrace:
:[ INFO: possible recursive locking detected ]
:3.0.0-1.fc16.x86_64 #1
:---------------------------------------------
:systemd-logind/866 is trying to acquire lock:
: (&ep->mtx){+.+.+.}, at: [<ffffffff8116ee12>] ep_scan_ready_list+0x3a/0x19f
:but task is already holding lock:
: (&ep->mtx){+.+.+.}, at: [<ffffffff8116f38c>] sys_epoll_ctl+0x120/0x51d
:other info that might help us debug this:
: Possible unsafe locking scenario:
:       CPU0
:       ----
:  lock(&ep->mtx);
:  lock(&ep->mtx);
: *** DEADLOCK ***
: May be due to missing lock nesting notation
:2 locks held by systemd-logind/866:
: #0:  (epmutex){+.+.+.}, at: [<ffffffff8116f344>] sys_epoll_ctl+0xd8/0x51d
: #1:  (&ep->mtx){+.+.+.}, at: [<ffffffff8116f38c>] sys_epoll_ctl+0x120/0x51d
:stack backtrace:
:Pid: 866, comm: systemd-logind Not tainted 3.0.0-1.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8108a375>] __lock_acquire+0x917/0xcf7
: [<ffffffff8100af3a>] ? dump_trace+0x2fe/0x30d
: [<ffffffff8100e9fd>] ? paravirt_read_tsc+0x9/0xd
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8108abe2>] lock_acquire+0xbf/0x103
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff81087ea6>] ? save_trace+0x3d/0xa7
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8116e8bf>] ? ep_remove+0xb4/0xb4
: [<ffffffff814dc8f2>] __mutex_lock_common+0x4c/0x361
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8100e9fd>] ? paravirt_read_tsc+0x9/0xd
: [<ffffffff8100eec7>] ? native_sched_clock+0x34/0x36
: [<ffffffff8100eed2>] ? sched_clock+0x9/0xd
: [<ffffffff8108986b>] ? mark_lock+0x2d/0x220
: [<ffffffff8116e8bf>] ? ep_remove+0xb4/0xb4
: [<ffffffff814dcd16>] mutex_lock_nested+0x40/0x45
: [<ffffffff8116ee12>] ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8116ef77>] ? ep_scan_ready_list+0x19f/0x19f
: [<ffffffff8116ef8e>] ep_poll_readyevents_proc+0x17/0x19
: [<ffffffff8116eb9d>] ep_call_nested.constprop.3+0x90/0xcc
: [<ffffffff8116ecc2>] ep_eventpoll_poll+0x4e/0x5d
: [<ffffffff8116f49e>] sys_epoll_ctl+0x232/0x51d
: [<ffffffff8116ea58>] ? ep_set_mstimeout+0x49/0x49
: [<ffffffff814e4fc2>] system_call_fastpath+0x16/0x1b
Comment 1 Josh Boyer 2011-08-16 19:02:26 EDT
This is fixed in

*** This bug has been marked as a duplicate of bug 722472 ***

Note You need to log in before you can comment on or make changes to this bug.