This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 73120 - usbview incorrectly parses/displays hex interface subclass/protocol IDs
usbview incorrectly parses/displays hex interface subclass/protocol IDs
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: usbview (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 18:21 EDT by David Paschal
Modified: 2013-03-13 00:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Paschal 2002-08-30 18:21:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.18-dsp1 i686)

Description of problem:
/proc/bus/usb/devices lists class/subclass/protocol IDs in hex, but usbview
incorrectly parses/displays the subclass/protocol IDs from interface descriptors
as decimal, meaning that if a device has any hex digits (A-F) in these fields,
they will be displayed incorrectly (possibly as 0).

See http://www.geocrawler.com/lists/3/SourceForge/2571/300/9358050/ for my
original notification to the upstream author, and
http://www.geocrawler.com/lists/3/SourceForge/2571/300/9358161/ for upstream
author's response.  See
http://hpoj.sourceforge.net/download/patches/usbview-1.0.patch for the patch
that I provided.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Feed usbview the following substitute for /proc/bus/usb/devices:

T:  Bus=01 Lev=03 Prnt=11 Port=03 Cnt=04 Dev#= 12 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=03f0 ProdID=2911 Rev= 1.00
S:  Manufacturer=Hewlett-Packard
S:  Product=PSC 2200 Series
S:  SerialNumber=MY24GB506B0G
C:* #Ifs= 4 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=cc Prot=00 Driver=(none)
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl= 10ms
I:  If#= 1 Alt= 0 #EPs= 3 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E:  Ad=03(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=83(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=84(I) Atr=03(Int.) MxPS=   8 Ivl= 10ms
I:  If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=05(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=85(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=86(I) Atr=03(Int.) MxPS=   8 Ivl= 10ms
I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=07(O) Atr=02(Bulk) MxPS=  32 Ivl=  0ms
E:  Ad=87(I) Atr=02(Bulk) MxPS=  32 Ivl=  0ms

Actual Results:  Interface numbers 0 and 2 display "0" for their subclass and
protocol ID fields.

Expected Results:  Interface 0 should display as ff/cc/00
(class/subclass/protocol ID), and interface 2 should display as ff/ff/ff.

Additional info:
Comment 1 John (J5) Palmieri 2004-08-25 13:29:34 EDT
I can't reproduce this.  Has this been fixed since Red Hat 8?
Comment 2 David Paschal 2004-09-08 15:04:54 EDT
It's still broken in FC2, with the same device as above (HP PSC 2210).
Comment 3 John (J5) Palmieri 2004-09-10 15:00:59 EDT
Fixed.  Will get into rawhide after FC3test2 is released.
Comment 4 Bill Nottingham 2006-08-04 16:37:24 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.