Bug 731212 - IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further
Summary: IOException: Partition(s) 3 on /dev/sda have been written, but we have been u...
Keywords:
Status: CLOSED DUPLICATE of bug 729640
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:165ecd0b0c1e59aa439e67aca68...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 00:30 UTC by Robert Lightfoot
Modified: 2011-08-17 21:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 00:57:44 UTC


Attachments (Terms of Use)
anaconda log (9.54 KB, application/octet-stream)
2011-08-17 00:40 UTC, Robert Lightfoot
no flags Details
ifcfg log (846 bytes, application/octet-stream)
2011-08-17 00:41 UTC, Robert Lightfoot
no flags Details
program log (17.87 KB, application/octet-stream)
2011-08-17 00:41 UTC, Robert Lightfoot
no flags Details
storage log (111.79 KB, application/octet-stream)
2011-08-17 00:42 UTC, Robert Lightfoot
no flags Details
xorg log (77.36 KB, application/octet-stream)
2011-08-17 00:42 UTC, Robert Lightfoot
no flags Details
kickstart file that failed (1.39 KB, text/plain)
2011-08-17 00:44 UTC, Robert Lightfoot
no flags Details

Description Robert Lightfoot 2011-08-17 00:30:33 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.i686
product:        Fedora
reason:         IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
time:           Tue Aug 16 20:29:17 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/parted/disk.py", line 213, in commit
:    return self.__disk.commit()
:  File "/usr/lib/python2.7/site-packages/parted/decorators.py", line 32, in new
:    ret = fn(*args, **kwds)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 263, in commit
:    self.partedDisk.commit()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 1547, in _destroy
:    self.disk.originalFormat.commit()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 825, in destroy
:    self._destroy()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 286, in execute
:    self.device.destroy()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 383, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 92, in return_false
:    func(*args, **kwargs)
:IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.

Comment 1 Robert Lightfoot 2011-08-17 00:40:51 UTC
Created attachment 518574 [details]
anaconda log

Comment 2 Robert Lightfoot 2011-08-17 00:41:13 UTC
Created attachment 518575 [details]
ifcfg log

Comment 3 Robert Lightfoot 2011-08-17 00:41:46 UTC
Created attachment 518576 [details]
program log

Comment 4 Robert Lightfoot 2011-08-17 00:42:14 UTC
Created attachment 518577 [details]
storage log

Comment 5 Robert Lightfoot 2011-08-17 00:42:42 UTC
Created attachment 518578 [details]
xorg log

Comment 6 Robert Lightfoot 2011-08-17 00:44:55 UTC
Created attachment 518579 [details]
kickstart file that failed

Suspect this may be the partition declarations in the ks rather than an f16 bug

Comment 7 Brian Lane 2011-08-17 00:57:44 UTC

*** This bug has been marked as a duplicate of bug 729640 ***


Note You need to log in before you can comment on or make changes to this bug.