Bug 731229 - Failure to resume from suspend to RAM when btusb is loaded
Summary: Failure to resume from suspend to RAM when btusb is loaded
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 04:37 UTC by Jonathan Briggs
Modified: 2011-10-01 00:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-01 00:09:26 UTC


Attachments (Terms of Use)

Description Jonathan Briggs 2011-08-17 04:37:54 UTC
Description of problem:
My Samsung Series 9 laptop failed to resume from suspend. 

Version-Release number of selected component (if applicable):
kernel-2.6.38.7-30.fc15.x86_64
kernel-2.6.40-4.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 15 with packages updated as of 8/15/2011.
2. Attach a Bluetooth mouse to the system and use it.
3. Run pm-suspend.
4. Wake the laptop from suspend.
  
Actual results:
The laptop freezes during resume.

Expected results:
The laptop should resume normal operation.

Additional info:

The Bluetooth identifiers from lsusb -v:
Bus 002 Device 003: ID 0a5c:219a Broadcom Corp.

The system is booting via UEFI and grub.efi. GRUB version is grub-0.97-71.fc15.x86_64

This was very puzzling because it only started to happen about two weeks ago (roughly the beginning of August 2011). It took me a very long time to figure this one out. At first I suspected the 3.0 / 2.6.40 kernel, but old kernels did not work any better. Then I suspected the changes I had made to the init scripts to implement the powertop suggested tunables. But it was none of these.

The culprit appears to be the recently updated and now working Bluetooth support in Fedora 15. Since I installed Fedora 15, I never could get Bluetooth to work with an Apple Magic Mouse. But now it does. I am not sure which update fixed it.

And oddly enough, if I do:
# systemctl stop bluetooth.service
# modprobe -r btusb
# pm-suspend

Things work.

Comment 1 Jonathan Briggs 2011-10-01 00:09:26 UTC
Closing my bug because the failure to resume has nothing to do with btusb. Instead it seems to be a problem with cold boot. After a reboot resume works so in my testing, changing things to remove btusb and rebooting made me think removing btusb fixed it.

But in fact, resume seems to always work if I reboot first.


Note You need to log in before you can comment on or make changes to this bug.