Bug 731240 - Cannot stream pure audio ogg files in Alpha (RC5)
Summary: Cannot stream pure audio ogg files in Alpha (RC5)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker RejectedNTH
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 06:19 UTC by Adam Williamson
Modified: 2013-02-13 11:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 11:33:07 UTC


Attachments (Terms of Use)

Description Adam Williamson 2011-08-17 06:19:28 UTC
Running the desktop audio validation test - https://fedoraproject.org/wiki/QA:Testcase_audio_basic - on F16 Alpha RC5 desktop x86_64 live image (http://dl.fedoraproject.org/pub/alt/stage/16-Alpha.RC5/Live/x86_64/ ), I find that Totem seems not to be able to stream pure audio ogg files. I tried 'Open Location' on the example track from the test case, and also tried a different file from the vorbis.com site - http://www.vorbis.com/music/Epoq-Lepidoptera.ogg . In both cases Totem's status bar shows 'Buffering 0:00 / 0:00' for a short time, then 'Playing 0:00 / 0:00', with no music audible. gnome-volume-control shows 'No application is currently playing or recording audio'.

Audio itself is working okay, I can play the file within Firefox just fine. Also, streaming a *video* file seems to work - I tried Big Buck Bunny, the copy at http://mirrorblender.top-ix.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_stereo.ogg , with the same procedure and it played fine, with a correct duration displayed, video playing, and audio playing. Seems the problem is pure audio ogg/vorbis files only.

Running from a console doesn't show any obviously related errors, just a problem with permissions on ~/.local/share/recently-used.xbel.SUFFIX', which doesn't seem like it should cause this.

This is while booted live.

Comment 1 Tim Flink 2011-09-02 04:55:42 UTC
Proposing as a blocker for Fedora 16 beta because it interferes with the "audio basic" testcase [1] that is part of the desktop beta test plan.

[1] https://fedoraproject.org/wiki/QA:Testcase_audio_basic

Comment 2 Adam Williamson 2011-09-02 18:41:59 UTC
Discussed at 2011-09-02 blocker review meeting. Agreed this is not a blocker, as audio functionality itself is fine - this is more of a limited bug in Totem, that I just noticed while doing the audio test case.

Comment 3 Fedora End Of Life 2013-01-16 11:56:42 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Fedora End Of Life 2013-02-13 11:33:10 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.