Bug 731247 - gnome-tweak-tool crashes if started
Summary: gnome-tweak-tool crashes if started
Keywords:
Status: CLOSED DUPLICATE of bug 719791
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 07:01 UTC by Joachim Backes
Modified: 2011-08-23 07:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 07:25:42 UTC


Attachments (Terms of Use)

Description Joachim Backes 2011-08-17 07:01:32 UTC
Description of problem:
I installed gnome-tweak-tool in F16/Alpha/RC4/live/x86_64 after boot. If trying to start it, I see a crash:

gnome-tweak-tool
INFO    : Caching gsettings: <gtweak.gsettings._GSettingsSchema: org.gnome.desktop.interface>
Traceback (most recent call last):
  File "/usr/bin/gnome-tweak-tool", line 84, in <module>
    MainWindow()
  File "/usr/bin/gnome-tweak-tool", line 47, in __init__
    model)
  File "/usr/lib/python2.7/site-packages/gtweak/tweakview.py", line 40, in __init__
    self._model.load_tweaks()
  File "/usr/lib/python2.7/site-packages/gtweak/tweakmodel.py", line 103, in load_tweaks
    mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
  File "/usr/lib/python2.7/site-packages/gtweak/tweaks/tweak_font.py", line 28, in <module>
    GSettingsRangeTweak("org.gnome.desktop.interface", "text-scaling-factor", adjustment_step=0.1, size_group=sg),
  File "/usr/lib/python2.7/site-packages/gtweak/widgets.py", line 94, in __init__
    _min, _max = self.settings.get_range(key_name)[1]
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 44, in function
    return info.invoke(*args)
NotImplementedError: structure type 'GVariant' is not supported yet


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Joachim Backes 2011-08-17 07:05:41 UTC
(In reply to comment #0)
> Description of problem:
> I installed gnome-tweak-tool in F16/Alpha/RC4/live/x86_64 after boot. If trying
> to start it, I see a crash:
> 
> gnome-tweak-tool
> INFO    : Caching gsettings: <gtweak.gsettings._GSettingsSchema:
> org.gnome.desktop.interface>
> Traceback (most recent call last):
>   File "/usr/bin/gnome-tweak-tool", line 84, in <module>
>     MainWindow()
>   File "/usr/bin/gnome-tweak-tool", line 47, in __init__
>     model)
>   File "/usr/lib/python2.7/site-packages/gtweak/tweakview.py", line 40, in
> __init__
>     self._model.load_tweaks()
>   File "/usr/lib/python2.7/site-packages/gtweak/tweakmodel.py", line 103, in
> load_tweaks
>     mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
>   File "/usr/lib/python2.7/site-packages/gtweak/tweaks/tweak_font.py", line 28,
> in <module>
>     GSettingsRangeTweak("org.gnome.desktop.interface", "text-scaling-factor",
> adjustment_step=0.1, size_group=sg),
>   File "/usr/lib/python2.7/site-packages/gtweak/widgets.py", line 94, in
> __init__
>     _min, _max = self.settings.get_range(key_name)[1]
>   File "/usr/lib64/python2.7/site-packages/gi/types.py", line 44, in function
>     return info.invoke(*args)
> NotImplementedError: structure type 'GVariant' is not supported yet
> 
> 
> Version-Release number of selected component (if applicable):

rpm -q gnome-tweak-tool
gnome-tweak-tool-3.0.5-2.fc16.noarch


> 
> 

> How reproducible:
always

> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 2 Michel Alexandre Salim 2011-08-23 07:25:42 UTC

*** This bug has been marked as a duplicate of bug 719791 ***


Note You need to log in before you can comment on or make changes to this bug.