Bug 731266 - TypeError: must be string, not None
TypeError: must be string, not None
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
abrt_hash:e293737716b437919ae18bbe89b...
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-08-17 04:22 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-16.17-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error log of anaconda 16.14.6 (13.05 KB, text/x-log)
2011-08-17 04:41 EDT, Tao Wu
no flags Details
anaconda-tb-irzUih file (360.91 KB, text/plain)
2011-09-01 04:38 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2011-08-17 04:22:13 EDT
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.i686
product:        Fedora
reason:         TypeError: must be string, not None
time:           Wed Aug 17 04:20:20 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/isys/__init__.py", line 129, in mount
:    rc = _isys.mount(fstype, device, location, flags)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/image.py", line 172, in mountImage
:    isys.mount(image, tree, fstype = 'iso9660', readOnly = True)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 426, in _mountInstallImage
:    mountImage(self.isodir, self.tree, self.anaconda.intf.messageWindow)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 461, in configBaseURL
:    self._mountInstallImage()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 356, in setup
:    self.configBaseURL()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 1240, in doBackendSetup
:    self.ayum.setup()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/backend.py", line 192, in doBackendSetup
:    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:TypeError: must be string, not None
Comment 1 Tao Wu 2011-08-17 04:40:16 EDT
Steps to Reproduce:
1. Boot the installer using any available means (netinst.iso, pxeboot images or DVD.iso) 
2. Direct anaconda to use the package repo from a NFS server where your DVD iso images are stored by repo= boot command. For example:
   repo=nfsiso[:options]:<server>:/<path>
3. Proceed with installation 

Actual results:
anaconda crashed after partitioning

Expected results:
anaconda install successfully
Comment 2 Tao Wu 2011-08-17 04:41:20 EDT
Created attachment 518612 [details]
error log of anaconda 16.14.6
Comment 3 Tao Wu 2011-08-17 05:02:16 EDT
When I used http://akozumpl.fedorapeople.org/bz_dispatcher.img as an update, this problem didn't show up.
Comment 4 Chris Lumens 2011-08-17 09:14:50 EDT
Please attach /tmp/anaconda-tb-* to this bug report.  I don't know why that's not getting attached automatically by abrt.  Thanks.
Comment 5 Tao Wu 2011-09-01 04:38:13 EDT
Created attachment 520976 [details]
anaconda-tb-irzUih file
Comment 6 Tao Wu 2011-09-01 04:39:39 EDT
(In reply to comment #4)
> Please attach /tmp/anaconda-tb-* to this bug report.  I don't know why that's
> not getting attached automatically by abrt.  Thanks.

Hi Chris,

It still happens on anaconda 16.16, and I have upload the anaconda-tb-irzUih file, please have a look. Thanks!
Comment 7 Tim Flink 2011-09-02 01:07:06 EDT
Proposing as blocker for Fedora 16 final because it interferes with the "NFSISO install variation" test case [1] which is part of the final milestone of the install test plan.

[1] https://fedoraproject.org/wiki/QA:Testcase_install_repository_NFSISO_variation
Comment 8 Ales Kozumplik 2011-09-08 07:41:27 EDT
Tao,

Please retest with: updates=http://akozumpl.fedorapeople.org/bz731266.img

Thank you.
Comment 9 Fedora Update System 2011-09-08 13:28:56 EDT
anaconda-16.17-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.17-1.fc16
Comment 10 Fedora Update System 2011-09-08 16:49:59 EDT
Package anaconda-16.17-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.17-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.17-1.fc16
then log in and leave karma (feedback).
Comment 11 Ales Kozumplik 2011-09-09 02:08:56 EDT
(In reply to comment #9)
> anaconda-16.17-1.fc16 has been submitted as an update for Fedora 16.
> https://admin.fedoraproject.org/updates/anaconda-16.17-1.fc16

what the hell? makes the update system think this has been fixed in 16.17?

Tao, can you please retest with my comment 8? I think you shouldn't hit the traceback now though you still won't be able to install because your image architecture doesn't match that of your system.
Comment 12 Ales Kozumplik 2011-09-12 07:46:04 EDT
Patch posted for a review: https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00088.html
Comment 13 Ales Kozumplik 2011-09-13 04:40:40 EDT
Fixed:

4cc99ec584a8b229533f627f9e757087080f4c3d on f16-branch,
257d98f38536f50ba6546946be8b953f6b3a8b33 on master.
Comment 14 Fedora Update System 2011-09-30 15:38:42 EDT
anaconda-16.17-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.